Fix build for individual profiles with dashes in names
[openwrt/staging/yousong.git] / include / target.mk
index eca218e0b370ee9649fae694be90fa57a8a5786c..ccec41f71ce9e155b265deba067e0f176bb87066 100644 (file)
@@ -76,7 +76,7 @@ define Profile
        $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;
-  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
+  ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
     PROFILE=$(1)
   endif
 endef