add a command for printing a cleaned up make target database - will be used to analyz...
[openwrt/staging/yousong.git] / include / toplevel.mk
index 1b72f5443e3e0751cdcbc66a01a86402af7822c9..dee43cba985c1eb14ce152eeafd255116218a3e9 100644 (file)
@@ -114,6 +114,9 @@ tmp/.prereq-build: include/prereq-build.mk
        }
        touch $@
 
+printdb: FORCE
+       @$(_SINGLE)$(NO_TRACE_MAKE) -p $@ V=99 DUMP_TARGET_DB=1 2>&1
+
 download: .config FORCE
        @+$(SUBMAKE) tools/download
        @+$(SUBMAKE) toolchain/download