get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt/staging/yousong.git] / package / base-files / Makefile
index 41dc3106786c8cf72e13f99a8f2384639fbd3493..440562b877304012a8da6dd188d79d99ecc9a9d5 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=14
+PKG_RELEASE:=18
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
@@ -30,6 +29,10 @@ else
   LIBGCC_VERSION:=<LIBGCC_VERSION>
 endif
 
+ifneq ($(LIBC_VERSION),0.9.28)
+  LIBC_VERSION:=$(LIBC_VERSION)$(LIBC_PATCHVER)
+endif
+
 CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
 
 define Package/base-files$(TARGET)
@@ -113,12 +116,16 @@ $(call Package/libc/Default)
 endef
 
 define Package/ldd
-$(call Package/uclibc/Default)
+$(call Package/libc/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
   TITLE:=LDD trace utility
 endef
 
 define Package/ldconfig
 $(call Package/libc/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
   TITLE:=Shared library path configuration
 endef