firewall: do not check for module availability, let iptables fail if a feature is...
[openwrt/staging/yousong.git] / package / firewall / Makefile
index a8a62c287d033d153a0b20f2a11e3778a9599b69..749f04a4b1b7768c7682a0a5c451ccb86423fdb1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=23
+PKG_RELEASE:=36
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -51,6 +51,8 @@ define Package/firewall/install
        $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/firewall.user $(1)/etc
+       $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
+       $(INSTALL_DATA) ./files/firewall.upgrade $(1)/lib/upgrade/keep.d/firewall
 endef
 
 $(eval $(call BuildPackage,firewall))