hostapd: upgrade to latest git version, add patches to fix multi-bss support with...
[openwrt/staging/yousong.git] / package / hostapd / Makefile
index 606ec6736014b1b13521dee54b54b90020eddb13..682d6ab8524e4aab0e366708731176348993c7dd 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=20091111
+PKG_VERSION:=20100117
 PKG_RELEASE:=1
-PKG_REV:=dc6d9ac250f793a62b21ca828445967fb484305f
+PKG_REV:=43a7fe2e0e614e52fa05ff4d78af91bd4e17d3b2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
@@ -80,9 +80,18 @@ define Package/hostapd-utils/description
  IEEE 802.1x/WPA/EAP/RADIUS Authenticator.
 endef
 
-define Build/Configure
+ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
+  $(warning $(wildcard $(PKG_BUILD_DIR)/.config_*) != $(subst .configured_,.config_,$(STAMP_CONFIGURED)))
+  define Build/Configure/rebuild
+       $(FIND) $(PKG_BUILD_DIR) -name \*.o | $(XARGS) rm -f
        rm -f $(PKG_BUILD_DIR)/hostapd/hostapd
-       rm -f $(PKG_BUILD_DIR)/src/drivers/drivers.o
+       rm -f $(PKG_BUILD_DIR)/.config_*
+       touch $(subst .configured_,.config_,$(STAMP_CONFIGURED))
+  endef
+endif
+
+define Build/Configure
+       $(Build/Configure/rebuild)
        $(CP) ./files/$(BUILD_VARIANT).config $(PKG_BUILD_DIR)/hostapd/.config
 endef
 
@@ -108,22 +117,19 @@ define Build/Compile
                hostapd hostapd_cli
 endef
 
-define Package/InstallTemplate
+define Package/hostapd/install
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+       $(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
        $(INSTALL_DIR) $(1)/lib/wifi
        $(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/wifi/hostapd.sh
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
 endef
-
-ifeq ($(BUILD_VARIANT),full)
-  Package/hostapd/install = $(Package/InstallTemplate)
-else
-  Package/hostapd-mini/install = $(Package/InstallTemplate)
-endif
+Package/hostapd-mini/install = $(Package/hostapd/install)
 
 define Package/hostapd-utils/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd_cli $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,hostapd))