get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt/staging/yousong.git] / package / iproute2 / Makefile
index 645d0349f496e584c1e546d279e180cc021ce6d3..a05f0cdfe122a3962d85fc494c296efae408d2bb 100644 (file)
@@ -4,18 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=2.6.15-060110
+PKG_VERSION:=2.6.25
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
+PKG_MD5SUM:=5737bade2f5e03fad0e2c81da91e551e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
 
@@ -28,15 +26,20 @@ define Package/iproute2/Default
 endef
 
 define Package/ip
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=Routing control utility
 endef
 
 define Package/tc
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=Traffic control utility
 endef
 
+define Package/genl
+$(call Package/iproute2/Default)
+  TITLE:=General netlink utility frontend
+endef
+
 define Build/Configure
        $(SED) "s:-O2:${TARGET_CFLAGS}:g" $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,-I/usr/include/db3,," $(PKG_BUILD_DIR)/Makefile
@@ -56,6 +59,8 @@ endef
 
 define Package/ip/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/iproute2
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
@@ -64,5 +69,15 @@ define Package/tc/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
 endef
 
+define Package/genl/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
+$(eval $(call BuildPackage,genl))
+
+$(eval $(call RequireCommand,bison, \
+       $(PKG_NAME) requires GNU bison. \
+))