mac80211: put the !LINUX_4_4 dependency in the right place
[openwrt/staging/yousong.git] / package / kernel / mac80211 / Makefile
index 4b4f774c40bc093da71cb6973e91b38b1d40a84e..46d5420c0de04eea921311b116f051fa7dbfdeaf 100644 (file)
@@ -71,6 +71,7 @@ WMENU:=Wireless Drivers
 
 define KernelPackage/mac80211/Default
   SUBMENU:=$(WMENU)
+  DEPENDS:=@!LINUX_4_4
   URL:=https://wireless.wiki.kernel.org/
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 endef
@@ -1823,11 +1824,11 @@ endef
 
 
 define KernelPackage/ath9k-htc/install
-       $(INSTALL_DIR) $(1)/lib/firmware
+       $(INSTALL_DIR) $(1)/lib/firmware/ath9k_htc
        $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/htc_9271.fw \
-               $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/htc_7010.fw \
-               $(1)/lib/firmware/
+               $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/ath9k_htc/htc_9271-1.4.0.fw \
+               $(PKG_BUILD_DIR)/$(PKG_LINUX_FIRMWARE_SUBDIR)/ath9k_htc/htc_7010-1.4.0.fw \
+               $(1)/lib/firmware/ath9k_htc
 endef
 
 define KernelPackage/b43/install