mac80211: update to wireless-testing 2015-10-26
[openwrt/staging/yousong.git] / package / kernel / mac80211 / patches / 100-remove-cryptoapi-dependencies.patch
index 07dde5481cb4c9f9810a3a1113ed3751ae659be0..02f46c778d8cd704b96af062ea73c2cffbf2c19a 100644 (file)
@@ -7,11 +7,11 @@
 -      select BPAUTO_CRYPTO_CCM
 -      depends on CRYPTO_GCM
        depends on CRC32
-       select BPAUTO_AVERAGE
        ---help---
+         This option enables the hardware independent IEEE 802.11
 --- a/net/mac80211/Makefile
 +++ b/net/mac80211/Makefile
-@@ -15,9 +15,7 @@ mac80211-y := \
+@@ -16,9 +16,7 @@ mac80211-y := \
        michael.o \
        tkip.o \
        aes_ccm.o \
                struct {
 --- a/net/mac80211/wpa.c
 +++ b/net/mac80211/wpa.c
-@@ -304,7 +304,8 @@ ieee80211_crypto_tkip_decrypt(struct iee
+@@ -307,7 +307,8 @@ ieee80211_crypto_tkip_decrypt(struct iee
  }
  
  
  {
        __le16 mask_fc;
        int a4_included, mgmt;
-@@ -334,14 +335,8 @@ static void ccmp_special_blocks(struct s
+@@ -337,14 +338,8 @@ static void ccmp_special_blocks(struct s
        else
                qos_tid = 0;
  
  
        /* Nonce: Nonce Flags | A2 | PN
         * Nonce Flags: Priority (b0..b3) | Management (b4) | Reserved (b5..b7)
-@@ -349,6 +344,8 @@ static void ccmp_special_blocks(struct s
+@@ -352,6 +347,8 @@ static void ccmp_special_blocks(struct s
        b_0[1] = qos_tid | (mgmt << 4);
        memcpy(&b_0[2], hdr->addr2, ETH_ALEN);
        memcpy(&b_0[8], pn, IEEE80211_CCMP_PN_LEN);
  
        /* AAD (extra authenticate-only data) / masked 802.11 header
         * FC | A1 | A2 | A3 | SC | [A4] | [QC] */
-@@ -460,7 +457,7 @@ static int ccmp_encrypt_skb(struct ieee8
+@@ -463,7 +460,7 @@ static int ccmp_encrypt_skb(struct ieee8
                return 0;
  
        pos += IEEE80211_CCMP_HDR_LEN;
        ieee80211_aes_ccm_encrypt(key->u.ccmp.tfm, b_0, aad, pos, len,
                                  skb_put(skb, mic_len), mic_len);
  
-@@ -531,7 +528,7 @@ ieee80211_crypto_ccmp_decrypt(struct iee
+@@ -534,7 +531,7 @@ ieee80211_crypto_ccmp_decrypt(struct iee
                        u8 aad[2 * AES_BLOCK_SIZE];
                        u8 b_0[AES_BLOCK_SIZE];
                        /* hardware didn't decrypt/verify MIC */