get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt/staging/yousong.git] / package / kernel / modules / block.mk
index c37ff6d9a8392e7e8195a9df2e56fcc2600c400a..3c2781397297e18a7fd56f9c307742d4bfb066d7 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 BLOCK_MENU:=Block Devices
 
@@ -70,7 +69,7 @@ $(eval $(call KernelPackage,ata-ixp4xx-cf))
 define KernelPackage/ata-rb532-cf
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=RB532 Compact Flash support
-  DEPENDS:=kmod-ata-core
+  DEPENDS:=@TARGET_rb532 kmod-ata-core @BROKEN
   KCONFIG:= \
        CONFIG_PATA_PLATFORM \
        CONFIG_PATA_RB532
@@ -131,6 +130,7 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+# XXX: broken on 2.6.28 due to module name/path changes
 define KernelPackage/ide-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=IDE (ATA/ATAPI) device support
@@ -182,7 +182,11 @@ define KernelPackage/ide-aec62xx
   TITLE:=Acard AEC62xx IDE driver
   DEPENDS:=@PCI_SUPPORT +kmod-ide-core
   KCONFIG:=CONFIG_BLK_DEV_AEC62XX
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.28)),1)
+  FILES:=$(LINUX_DIR)/drivers/ide/aec62xx.$(LINUX_KMOD_SUFFIX)
+else
   FILES:=$(LINUX_DIR)/drivers/ide/pci/aec62xx.$(LINUX_KMOD_SUFFIX)
+endif
   AUTOLOAD:=$(call AutoLoad,30,aec62xx)
 endef
 
@@ -315,3 +319,18 @@ define KernelPackage/aoe/description
 endef
 
 $(eval $(call KernelPackage,aoe))
+
+define KernelPackage/ps3vram
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=PS3 Video RAM Storage Driver
+  DEPENDS:=@TARGET_ps3
+  KCONFIG:=CONFIG_PS3_VRAM
+  FILES:=$(LINUX_DIR)/drivers/block/ps3vram.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,01,ps3vram)
+endef
+
+define KernelPackage/ps3vram/description
+  Kernel support for PS3 Video RAM Storage
+endef
+
+$(eval $(call KernelPackage,ps3vram))