lantiq: Tune the XWAY subtarget cflags
[openwrt/staging/yousong.git] / package / kernel / modules / fs.mk
index b8bfa899fd1610a7670aa2e3842f2b2258f11a0c..ecdfb6d3a72b80ef2b08edd51852e955fbbe1eb8 100644 (file)
@@ -10,7 +10,7 @@ FS_MENU:=Filesystems
 define KernelPackage/fs-autofs4
   SUBMENU:=$(FS_MENU)
   TITLE:=AUTOFS4 filesystem support
-  KCONFIG:=CONFIG_AUTOFS4_FS 
+  KCONFIG:=CONFIG_AUTOFS4_FS
   FILES:=$(LINUX_DIR)/fs/autofs4/autofs4.ko
   AUTOLOAD:=$(call AutoLoad,30,autofs4)
 endef
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,fs-autofs4))
 define KernelPackage/fs-btrfs
   SUBMENU:=$(FS_MENU)
   TITLE:=BTRFS filesystem support
-  DEPENDS:=+kmod-lib-crc32c +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37):kmod-lib-lzo +kmod-lib-zlib
+  DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib
   KCONFIG:=\
        CONFIG_BTRFS_FS \
        CONFIG_BTRFS_FS_POSIX_ACL=n \
@@ -53,12 +53,13 @@ define KernelPackage/fs-cifs
   AUTOLOAD:=$(call AutoLoad,30,cifs)
   $(call AddDepends/nls)
   DEPENDS+= \
-    +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-arc4 \
-    +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-hmac \
-    +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-md5 \
-    +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37):kmod-crypto-md4 \
-    +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-des \
-    +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-ecb
+    +kmod-crypto-arc4 \
+    +kmod-crypto-hmac \
+    +kmod-crypto-md5 \
+    +kmod-crypto-md4 \
+    +kmod-crypto-des \
+    +kmod-crypto-ecb \
+    +!LINUX_3_3&&!LINUX_3_6:kmod-crypto-sha256
 endef
 
 define KernelPackage/fs-cifs/description
@@ -68,6 +69,22 @@ endef
 $(eval $(call KernelPackage,fs-cifs))
 
 
+define KernelPackage/fs-configfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Configuration filesystem support
+  KCONFIG:= \
+       CONFIG_CONFIGFS_FS
+  FILES:=$(LINUX_DIR)/fs/configfs/configfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,configfs)
+endef
+
+define KernelPackage/fs-configfs/description
+ Kernel module for configfs support
+endef
+
+$(eval $(call KernelPackage,fs-configfs))
+
+
 define KernelPackage/fs-exportfs
   SUBMENU:=$(FS_MENU)
   TITLE:=exportfs kernel server support
@@ -83,42 +100,6 @@ endef
 $(eval $(call KernelPackage,fs-exportfs))
 
 
-define KernelPackage/fs-ext2
-  SUBMENU:=$(FS_MENU)
-  TITLE:=EXT2 filesystem support
-  KCONFIG:=CONFIG_EXT2_FS
-  DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31
-  FILES:=$(LINUX_DIR)/fs/ext2/ext2.ko
-  AUTOLOAD:=$(call AutoLoad,32,ext2,1)
-endef
-
-define KernelPackage/fs-ext2/description
- Kernel module for EXT2 filesystem support
-endef
-
-$(eval $(call KernelPackage,fs-ext2,1))
-
-
-define KernelPackage/fs-ext3
-  SUBMENU:=$(FS_MENU)
-  TITLE:=EXT3 filesystem support
-  KCONFIG:= \
-       CONFIG_EXT3_FS \
-       CONFIG_JBD
-  DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31
-  FILES:= \
-       $(LINUX_DIR)/fs/ext3/ext3.ko \
-       $(LINUX_DIR)/fs/jbd/jbd.ko
-  AUTOLOAD:=$(call AutoLoad,31,jbd ext3,1)
-endef
-
-define KernelPackage/fs-ext3/description
- Kernel module for EXT3 filesystem support
-endef
-
-$(eval $(call KernelPackage,fs-ext3))
-
-
 define KernelPackage/fs-ext4
   SUBMENU:=$(FS_MENU)
   TITLE:=EXT4 filesystem support
@@ -127,15 +108,10 @@ define KernelPackage/fs-ext4
        CONFIG_JBD2
   FILES:= \
        $(LINUX_DIR)/fs/ext4/ext4.ko \
-       $(LINUX_DIR)/fs/jbd2/jbd2.ko
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
-    FILES+= \
+       $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
-    AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
- else
-    AUTOLOAD:=$(call AutoLoad,30,jbd2 ext4,1)
- endif
-  $(call AddDepends/crc16)
+  AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
+  $(call AddDepends/crc16, +!LINUX_3_3:kmod-crypto-hash)
 endef
 
 define KernelPackage/fs-ext4/description
@@ -145,9 +121,24 @@ endef
 $(eval $(call KernelPackage,fs-ext4))
 
 
+define KernelPackage/fuse
+  SUBMENU:=$(FS_MENU)
+  TITLE:=FUSE (Filesystem in Userspace) support
+  KCONFIG:= CONFIG_FUSE_FS
+  FILES:=$(LINUX_DIR)/fs/fuse/fuse.ko
+  AUTOLOAD:=$(call AutoLoad,80,fuse)
+endef
+
+define KernelPackage/fuse/description
+ Kernel module for userspace filesystem support
+endef
+
+$(eval $(call KernelPackage,fuse))
+
+
 define KernelPackage/fs-hfs
   SUBMENU:=$(FS_MENU)
-  TITLE:=HFS+ filesystem support
+  TITLE:=HFS filesystem support
   KCONFIG:=CONFIG_HFS_FS
   FILES:=$(LINUX_DIR)/fs/hfs/hfs.ko
   AUTOLOAD:=$(call AutoLoad,30,hfs)
@@ -180,6 +171,7 @@ $(eval $(call KernelPackage,fs-hfsplus))
 define KernelPackage/fs-isofs
   SUBMENU:=$(FS_MENU)
   TITLE:=ISO9660 filesystem support
+  DEPENDS:=+kmod-lib-zlib
   KCONFIG:=CONFIG_ISO9660_FS CONFIG_JOLIET=y CONFIG_ZISOFS=n
   FILES:=$(LINUX_DIR)/fs/isofs/isofs.ko
   AUTOLOAD:=$(call AutoLoad,30,isofs)