kernel: add kmod-mcp23s08 package
[openwrt/staging/yousong.git] / package / kernel / modules / other.mk
index 3781cbe329de00badbb99bc1e8160316141c04b1..f282014a30637a05e694654185152b403e76bc49 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,27 +24,27 @@ define KernelPackage/bluetooth
        CONFIG_BLUEZ_HCIUSB \
        CONFIG_BLUEZ_HIDP \
        CONFIG_BT \
-       CONFIG_BT_L2CAP \
-       CONFIG_BT_SCO \
+       CONFIG_BT_L2CAP=y \
+       CONFIG_BT_SCO=y \
        CONFIG_BT_RFCOMM \
        CONFIG_BT_BNEP \
        CONFIG_BT_HCIBTUSB \
        CONFIG_BT_HCIUSB \
        CONFIG_BT_HCIUART \
-       CONFIG_BT_HIDP
+       CONFIG_BT_HCIUART_H4 \
+       CONFIG_BT_HIDP \
+       CONFIG_HID_SUPPORT=y
   $(call AddDepends/crc16)
   $(call AddDepends/hid)
   $(call AddDepends/rfkill)
   FILES:= \
        $(LINUX_DIR)/net/bluetooth/bluetooth.ko \
-       $(LINUX_DIR)/net/bluetooth/l2cap.ko \
-       $(LINUX_DIR)/net/bluetooth/sco.ko \
        $(LINUX_DIR)/net/bluetooth/rfcomm/rfcomm.ko \
        $(LINUX_DIR)/net/bluetooth/bnep/bnep.ko \
        $(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
        $(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
        $(LINUX_DIR)/drivers/bluetooth/btusb.ko
-  AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+  AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
 endef
 
 define KernelPackage/bluetooth/description
@@ -54,65 +54,20 @@ endef
 $(eval $(call KernelPackage,bluetooth))
 
 
-define KernelPackage/crc-ccitt
+define KernelPackage/bluetooth-hci-h4p
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=CRC-CCITT support
-  KCONFIG:=CONFIG_CRC_CCITT
-  FILES:=$(LINUX_DIR)/lib/crc-ccitt.ko
-  AUTOLOAD:=$(call AutoLoad,20,crc-ccitt)
+  TITLE:=HCI driver with H4 Nokia extensions
+  DEPENDS:=@TARGET_omap24xx +kmod-bluetooth
+  KCONFIG:=CONFIG_BT_HCIH4P
+  FILES:=$(LINUX_DIR)/drivers/bluetooth/hci_h4p/hci_h4p.ko
+  AUTOLOAD:=$(call AutoLoad,91,hci_h4p)
 endef
 
-define KernelPackage/crc-ccitt/description
- Kernel module for CRC-CCITT support
+define KernelPackage/bluetooth-hci-h4p/description
+  HCI driver with H4 Nokia extensions
 endef
 
-$(eval $(call KernelPackage,crc-ccitt))
-
-
-define KernelPackage/crc-itu-t
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CRC ITU-T V.41 support
-  KCONFIG:=CONFIG_CRC_ITU_T
-  FILES:=$(LINUX_DIR)/lib/crc-itu-t.ko
-  AUTOLOAD:=$(call AutoLoad,20,crc-itu-t)
-endef
-
-define KernelPackage/crc-itu-t/description
- Kernel module for CRC ITU-T V.41 support
-endef
-
-$(eval $(call KernelPackage,crc-itu-t))
-
-
-define KernelPackage/crc7
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CRC7 support
-  KCONFIG:=CONFIG_CRC7
-  FILES:=$(LINUX_DIR)/lib/crc7.ko
-  AUTOLOAD:=$(call AutoLoad,20,crc7)
-endef
-
-define KernelPackage/crc7/description
- Kernel module for CRC7 support
-endef
-
-$(eval $(call KernelPackage,crc7))
-
-
-define KernelPackage/crc16
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CRC16 support
-  KCONFIG:=CONFIG_CRC16
-  FILES:=$(LINUX_DIR)/lib/crc16.ko
-  AUTOLOAD:=$(call AutoLoad,20,crc16,1)
-  $(call SetDepends/crc16)
-endef
-
-define KernelPackage/crc16/description
- Kernel module for CRC16 support
-endef
-
-$(eval $(call KernelPackage,crc16))
+$(eval $(call KernelPackage,bluetooth-hci-h4p))
 
 
 define KernelPackage/eeprom-93cx6
@@ -130,20 +85,35 @@ endef
 $(eval $(call KernelPackage,eeprom-93cx6))
 
 
-define KernelPackage/gpio-cs5535
+define KernelPackage/eeprom-at24
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=EEPROM AT24 support
+  KCONFIG:=CONFIG_EEPROM_AT24
+  DEPENDS:=+kmod-i2c-core
+  FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at24.ko
+  AUTOLOAD:=$(call AutoLoad,60,at24)
+endef
+
+define KernelPackage/eeprom-at24/description
+ Kernel module for most I2C EEPROMs
+endef
+
+$(eval $(call KernelPackage,eeprom-at24))
+
+
+define KernelPackage/eeprom-at25
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=AMD CS5535/CS5536 GPIO driver
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_CS5535_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
+  TITLE:=EEPROM AT25 support
+  KCONFIG:=CONFIG_EEPROM_AT25
+  FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at25.ko
+  AUTOLOAD:=$(call AutoLoad,61,at25)
 endef
 
-define KernelPackage/gpio-cs5535/description
- This package contains the AMD CS5535/CS5536 GPIO driver
+define KernelPackage/eeprom-at25/description
+ Kernel module for most SPI EEPROMs
 endef
 
-$(eval $(call KernelPackage,gpio-cs5535))
+$(eval $(call KernelPackage,eeprom-at25))
 
 
 define KernelPackage/gpio-dev
@@ -162,534 +132,555 @@ endef
 $(eval $(call KernelPackage,gpio-dev))
 
 
-define KernelPackage/gpio-nsc
+define KernelPackage/gpio-mcp23s08
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi GPIO support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_NSC_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/nsc_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,40,nsc_gpio)
+  TITLE:=Microchip MCP23xxx I/O expander
+  DEPENDS:=@GPIO_SUPPORT
+  KCONFIG:=CONFIG_GPIO_MCP23S08
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
+  AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)
 endef
 
-define KernelPackage/gpio-nsc/description
- Kernel module for Natsemi GPIO
+define KernelPackage/gpio-mcp23s08/description
+  Kernel module for Microchip MCP23xxx SPI/I2C I/O expander
 endef
 
-$(eval $(call KernelPackage,gpio-nsc))
+$(eval $(call KernelPackage,gpio-mcp23s08))
 
 
-define KernelPackage/gpio-pc8736x
+define KernelPackage/gpio-nxp-74hc164
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=PC8736x GPIO support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_PC8736x_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/pc8736x_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,40,pc8736x_gpio)
+  TITLE:=NXP 74HC164 GPIO expander support
+  KCONFIG:=CONFIG_GPIO_NXP_74HC164
+  FILES:=$(LINUX_DIR)/drivers/gpio/nxp_74hc164.ko
+  AUTOLOAD:=$(call AutoLoad,99,nxp_74hc164)
 endef
 
-define KernelPackage/gpio-pc8736x/description
- Kernel module for PC8736x GPIO
+define KernelPackage/gpio-nxp-74hc164/description
+  Kernel module for NXP 74HC164 GPIO expander
 endef
 
-$(eval $(call KernelPackage,gpio-pc8736x))
-
+$(eval $(call KernelPackage,gpio-nxp-74hc164))
 
-define KernelPackage/gpio-scx200
+define KernelPackage/gpio-pcf857x
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi SCX200 GPIO support
-  DEPENDS:=@TARGET_x86 +kmod-gpio-nsc
-  KCONFIG:=CONFIG_SCx200_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/scx200_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,50,scx200_gpio)
+  DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+  TITLE:=PCX857x, PCA967x and MAX732X I2C GPIO expanders
+  KCONFIG:=CONFIG_GPIO_PCF857X
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-pcf857x.ko
+  AUTOLOAD:=$(call AutoLoad,55,gpio-pcf857x)
 endef
 
-define KernelPackage/gpio-scx200/description
- Kernel module for SCX200 GPIO
+define KernelPackage/gpio-pcf857x/description
+  Kernel module for PCF857x, PCA{85,96}7x, and MAX732[89] I2C GPIO expanders
 endef
 
-$(eval $(call KernelPackage,gpio-scx200))
+$(eval $(call KernelPackage,gpio-pcf857x))
 
-define KernelPackage/gpio-nxp-74hc164
+define KernelPackage/lp
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=NXP 74HC164 GPIO expander support
-  DEPENDS:=@TARGET_brcm63xx
-  KCONFIG:=CONFIG_GPIO_NXP_74HC164
-  FILES:=$(LINUX_DIR)/drivers/gpio/nxp_74hc164.ko
-  AUTOLOAD:=$(call AutoLoad,99,nxp_74hc164)
+  TITLE:=Parallel port and line printer support
+  DEPENDS:=@BROKEN
+  KCONFIG:= \
+       CONFIG_PARPORT \
+       CONFIG_PRINTER \
+       CONFIG_PPDEV
+  FILES:= \
+       $(LINUX_DIR)/drivers/parport/parport.ko \
+       $(LINUX_DIR)/drivers/char/lp.ko \
+       $(LINUX_DIR)/drivers/char/ppdev.ko
+  AUTOLOAD:=$(call AutoLoad,50,parport lp)
 endef
 
-define KernelPackage/gpio-nxp-74hc164/description
-  Kernel module for NXP 74HC164 GPIO expander
-endef
+$(eval $(call KernelPackage,lp))
 
-$(eval $(call KernelPackage,gpio-nxp-74hc164))
 
-define KernelPackage/hid
+define KernelPackage/mmc
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=HID Devices
-  DEPENDS:=+kmod-input-evdev
-  KCONFIG:=CONFIG_HID
-  FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
-  AUTOLOAD:=$(call AutoLoad,61,hid)
-  $(call SetDepends/hid)
-  $(call AddDepends/input)
+  TITLE:=MMC/SD Card Support
+  KCONFIG:= \
+       CONFIG_MMC \
+       CONFIG_MMC_BLOCK \
+       CONFIG_MMC_DEBUG=n \
+       CONFIG_MMC_UNSAFE_RESUME=n \
+       CONFIG_MMC_BLOCK_BOUNCE=y \
+       CONFIG_MMC_SDHCI=n \
+       CONFIG_MMC_TIFM_SD=n \
+       CONFIG_MMC_WBSD=n \
+       CONFIG_SDIO_UART=n
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/core/mmc_core.ko \
+       $(LINUX_DIR)/drivers/mmc/card/mmc_block.ko
+  AUTOLOAD:=$(call AutoLoad,90,mmc_core mmc_block,1)
 endef
 
-define KernelPackage/hid/description
- Kernel modules for HID devices
+define KernelPackage/mmc/description
+ Kernel support for MMC/SD cards
 endef
 
-$(eval $(call KernelPackage,hid))
+$(eval $(call KernelPackage,mmc))
 
 
-define KernelPackage/input-core
+define KernelPackage/oprofile
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Input device core
-  KCONFIG:=CONFIG_INPUT
-  $(call SetDepends/input)
-  FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
-  AUTOLOAD:=$(call AutoLoad,19,input-core)
+  TITLE:=OProfile profiling support
+  KCONFIG:=CONFIG_OPROFILE
+  FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.ko
+  DEPENDS:=@KERNEL_PROFILING
 endef
 
-define KernelPackage/input-core/description
- Kernel modules for support of input device
+define KernelPackage/oprofile/description
+  Kernel module for support for oprofile system profiling.
 endef
 
-$(eval $(call KernelPackage,input-core))
+$(eval $(call KernelPackage,oprofile))
 
 
-define KernelPackage/input-evdev
+define KernelPackage/rfkill
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Input event device
-  KCONFIG:=CONFIG_INPUT_EVDEV
-  FILES:=$(LINUX_DIR)/drivers/input/evdev.ko
-  AUTOLOAD:=$(call AutoLoad,60,evdev)
-  $(call AddDepends/input)
+  TITLE:=RF switch subsystem support
+  KCONFIG:= \
+    CONFIG_RFKILL \
+    CONFIG_RFKILL_INPUT=y \
+    CONFIG_RFKILL_LEDS=y \
+    CONFIG_RFKILL_GPIO=y
+  FILES:= \
+    $(LINUX_DIR)/net/rfkill/rfkill.ko
+  AUTOLOAD:=$(call AutoLoad,20,rfkill)
+  $(call SetDepends/rfkill)
 endef
 
-define KernelPackage/input-evdev/description
- Kernel modules for support of input device events
+define KernelPackage/rfkill/description
+  Say Y here if you want to have control over RF switches
+  found on many WiFi and Bluetooth cards.
 endef
 
-$(eval $(call KernelPackage,input-evdev))
+$(eval $(call KernelPackage,rfkill))
 
 
-define KernelPackage/input-gpio-buttons
+define KernelPackage/softdog
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Polled GPIO buttons input device
-  DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
-  KCONFIG:= \
-       CONFIG_INPUT_GPIO_BUTTONS \
-       CONFIG_INPUT_MISC=y
-  FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons)
+  TITLE:=Software watchdog driver
+  KCONFIG:=CONFIG_SOFT_WATCHDOG
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/softdog.ko
+  AUTOLOAD:=$(call AutoLoad,50,softdog)
 endef
 
-define KernelPackage/input-gpio-buttons/description
- Kernel module for support polled GPIO buttons input device
+define KernelPackage/softdog/description
+ Software watchdog driver
 endef
 
-$(eval $(call KernelPackage,input-gpio-buttons))
+$(eval $(call KernelPackage,softdog))
 
 
-define KernelPackage/input-gpio-keys
+define KernelPackage/ssb
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=GPIO key support
-  DEPENDS:= @GPIO_SUPPORT
-  KCONFIG:=CONFIG_KEYBOARD_GPIO
-  FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
-  AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
-  $(call AddDepends/input)
+  TITLE:=Silicon Sonics Backplane glue code
+  DEPENDS:=@PCI_SUPPORT @!TARGET_brcm47xx @!TARGET_brcm63xx
+  KCONFIG:=\
+       CONFIG_SSB \
+       CONFIG_SSB_B43_PCI_BRIDGE=y \
+       CONFIG_SSB_DRIVER_MIPS=n \
+       CONFIG_SSB_DRIVER_PCICORE=y \
+       CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y \
+       CONFIG_SSB_PCIHOST=y \
+       CONFIG_SSB_PCIHOST_POSSIBLE=y \
+       CONFIG_SSB_POSSIBLE=y \
+       CONFIG_SSB_SPROM=y \
+       CONFIG_SSB_SILENT=y
+  FILES:=$(LINUX_DIR)/drivers/ssb/ssb.ko
+  AUTOLOAD:=$(call AutoLoad,29,ssb)
 endef
 
-define KernelPackage/input-gpio-keys/description
- This driver implements support for buttons connected
- to GPIO pins of various CPUs (and some other chips).
+define KernelPackage/ssb/description
+  Silicon Sonics Backplane glue code.
 endef
 
-$(eval $(call KernelPackage,input-gpio-keys))
+$(eval $(call KernelPackage,ssb))
 
 
-define KernelPackage/input-gpio-encoder
+define KernelPackage/bcma
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=GPIO rotay encoder
-  KCONFIG:=CONFIG_INPUT_GPIO_ROTARY_ENCODER
-  FILES:=$(LINUX_DIR)/drivers/input/misc/rotary_encoder.ko
-  AUTOLOAD:=$(call AutoLoad,62,rotary_encoder)
-  $(call AddDepends/input,@GPIO_SUPPORT)
+  TITLE:=BCMA support
+  DEPENDS:=@PCI_SUPPORT @!TARGET_brcm47xx
+  KCONFIG:=\
+       CONFIG_BCMA \
+       CONFIG_BCMA_POSSIBLE=y \
+       CONFIG_BCMA_BLOCKIO=y \
+       CONFIG_BCMA_HOST_PCI_POSSIBLE=y \
+       CONFIG_BCMA_HOST_PCI=y \
+       CONFIG_BCMA_DRIVER_MIPS=n \
+       CONFIG_BCMA_DRIVER_PCI_HOSTMODE=n \
+       CONFIG_BCMA_DRIVER_GMAC_CMN=n \
+       CONFIG_BCMA_DEBUG=n
+  FILES:=$(LINUX_DIR)/drivers/bcma/bcma.ko
+  AUTOLOAD:=$(call AutoLoad,29,bcma)
 endef
 
-define KernelPackage/gpio-encoder/description
- Kernel module to use rotary encoders connected to GPIO pins
+define KernelPackage/bcma/description
+   Bus driver for Broadcom specific Advanced Microcontroller Bus Architecture.
 endef
 
-$(eval $(call KernelPackage,input-gpio-encoder))
+$(eval $(call KernelPackage,bcma))
 
 
-define KernelPackage/input-joydev
+define KernelPackage/wdt-omap
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Joystick device support
-  KCONFIG:=CONFIG_INPUT_JOYDEV
-  FILES:=$(LINUX_DIR)/drivers/input/joydev.ko
-  AUTOLOAD:=$(call AutoLoad,62,joydev)
-  $(call AddDepends/input)
+  TITLE:=OMAP Watchdog timer
+  DEPENDS:=@(TARGET_omap24xx||TARGET_omap35xx)
+  KCONFIG:=CONFIG_OMAP_WATCHDOG
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko)
 endef
 
-define KernelPackage/input-joydev/description
-  Kernel module for joystick support
+define KernelPackage/wdt-omap/description
+  Kernel module for TI omap watchdog timer.
 endef
 
-$(eval $(call KernelPackage,input-joydev))
+$(eval $(call KernelPackage,wdt-omap))
 
 
-define KernelPackage/input-polldev
+define KernelPackage/wdt-orion
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Polled Input device support
-  KCONFIG:=CONFIG_INPUT_POLLDEV
-  FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-  AUTOLOAD:=$(call AutoLoad,20,input-polldev)
-  $(call AddDepends/input)
+  TITLE:=Marvell Orion Watchdog timer
+  DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
+  KCONFIG:=CONFIG_ORION_WATCHDOG
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
 endef
 
-define KernelPackage/input-polldev/description
- Kernel module for support of polled input devices
+define KernelPackage/wdt-orion/description
+  Kernel module for Marvell Orion, Kirkwood and Armada XP/370 watchdog timer.
 endef
 
-$(eval $(call KernelPackage,input-polldev))
+$(eval $(call KernelPackage,wdt-orion))
 
 
-define KernelPackage/leds-alix
+define KernelPackage/booke-wdt
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=PCengines ALIX LED support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_LEDS_ALIX2
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-alix2.ko
-  AUTOLOAD:=$(call AutoLoad,50,leds-alix2)
+  TITLE:=PowerPC Book-E Watchdog Timer
+  DEPENDS:=@(TARGET_mpc85xx||TARGET_ppc40x||TARGET_ppc44x)
+  KCONFIG:=CONFIG_BOOKE_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/booke_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,booke_wdt)
 endef
 
-define KernelPackage/leds-alix/description
- Kernel module for PCengines ALIX LEDs
+define KernelPackage/booke-wdt/description
+  Kernel module for PowerPC Book-E Watchdog Timer.
 endef
 
-$(eval $(call KernelPackage,leds-alix))
+$(eval $(call KernelPackage,booke-wdt))
 
 
-define KernelPackage/leds-gpio
+define KernelPackage/pwm
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=GPIO LED support
-  DEPENDS:= @GPIO_SUPPORT
-  KCONFIG:=CONFIG_LEDS_GPIO
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-gpio.ko
-  AUTOLOAD:=$(call AutoLoad,60,leds-gpio)
+  TITLE:=PWM generic API
+  KCONFIG:=CONFIG_GENERIC_PWM
+  FILES:=$(LINUX_DIR)/drivers/pwm/pwm.ko
+  AUTOLOAD:=$(call AutoLoad,50,pwm)
 endef
 
-define KernelPackage/leds-gpio/description
- Kernel module for LEDs on GPIO lines
+define KernelPackage/pwm/description
+ Kernel module that implement a generic PWM API
 endef
 
-$(eval $(call KernelPackage,leds-gpio))
+$(eval $(call KernelPackage,pwm))
 
 
-define KernelPackage/leds-net48xx
+define KernelPackage/pwm-gpio
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Soekris Net48xx LED support
-  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
-  KCONFIG:=CONFIG_LEDS_NET48XX
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-net48xx.ko
-  AUTOLOAD:=$(call AutoLoad,50,leds-net48xx)
+  TITLE:=PWM over GPIO
+  DEPENDS:=+kmod-pwm
+  KCONFIG:=CONFIG_GPIO_PWM
+  FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
+  AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
 endef
 
-define KernelPackage/leds-net48xx/description
- Kernel module for Soekris Net48xx LEDs
+define KernelPackage/pwm-gpio/description
+ Kernel module to models a single-channel PWM device using a timer and a GPIO pin
 endef
 
-$(eval $(call KernelPackage,leds-net48xx))
+$(eval $(call KernelPackage,pwm-gpio))
 
 
-define KernelPackage/leds-rb750
+define KernelPackage/rtc-isl1208
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=RouterBOARD 750 LED support
-  DEPENDS:=@TARGET_ar71xx
-  KCONFIG:=CONFIG_LEDS_RB750
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-rb750.ko
-  AUTOLOAD:=$(call AutoLoad,60,leds-rb750)
+  TITLE:=Intersil ISL1208 RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_ISL1208
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-isl1208.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-isl1208)
 endef
 
-define KernelPackage/leds-rb750/description
- Kernel module for the LEDs on the MikroTik RouterBOARD 750.
+define KernelPackage/rtc-isl1208/description
+ Kernel module for Intersil ISL1208 RTC.
 endef
 
-$(eval $(call KernelPackage,leds-rb750))
+$(eval $(call KernelPackage,rtc-isl1208))
 
 
-define KernelPackage/leds-wndr3700-usb
+define KernelPackage/rtc-marvell
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=WNDR3700 USB LED support
-  DEPENDS:=@TARGET_ar71xx
-  KCONFIG:=CONFIG_LEDS_WNDR3700_USB
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-wndr3700-usb.ko
-  AUTOLOAD:=$(call AutoLoad,60,leds-wndr3700-usb)
+  TITLE:=Marvell SoC built-in RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu
+  KCONFIG:=CONFIG_RTC_DRV_MV
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-mv)
 endef
 
-define KernelPackage/leds-wndr3700-usb/description
- Kernel module for the USB LED on the NETGWR WNDR3700 board.
+define KernelPackage/rtc-marvell/description
+ Kernel module for Marvell SoC built-in RTC.
 endef
 
-$(eval $(call KernelPackage,leds-wndr3700-usb))
-
+$(eval $(call KernelPackage,rtc-marvell))
 
-define KernelPackage/leds-wrap
+define KernelPackage/rtc-pcf8563
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=PCengines WRAP LED support
-  DEPENDS:=@TARGET_x86 +kmod-gpio-scx200
-  KCONFIG:=CONFIG_LEDS_WRAP
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-wrap.ko
-  AUTOLOAD:=$(call AutoLoad,50,leds-wrap)
+  TITLE:=Philips PCF8563/Epson RTC8564 RTC support
+  $(call AddDepends/rtc)
+  KCONFIG:=CONFIG_RTC_DRV_PCF8563
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf8563.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-pcf8563)
 endef
 
-define KernelPackage/leds-wrap/description
- Kernel module for PCengines WRAP LEDs
+define KernelPackage/rtc-pcf8563/description
+ Kernel module for Philips PCF8563 RTC chip.
+ The Epson RTC8564 should work as well.
 endef
 
-$(eval $(call KernelPackage,leds-wrap))
+$(eval $(call KernelPackage,rtc-pcf8563))
 
 
-define KernelPackage/ledtrig-morse
+define KernelPackage/rtc-pcf2123
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=LED Morse Trigger
-  KCONFIG:=CONFIG_LEDS_TRIGGER_MORSE
-  FILES:=$(LINUX_DIR)/drivers/leds/ledtrig-morse.ko
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-morse)
+  TITLE:=Philips PCF2123 RTC support
+  $(call AddDepends/rtc)
+  KCONFIG:=CONFIG_RTC_DRV_PCF2123
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)
 endef
 
-define KernelPackage/ledtrig-morse/description
- Kernel module to show morse coded messages on LEDs.
+define KernelPackage/rtc-pcf2123/description
+ Kernel module for Philips PCF2123 RTC chip.
 endef
 
-$(eval $(call KernelPackage,ledtrig-morse))
-
+$(eval $(call KernelPackage,rtc-pcf2123))
 
-define KernelPackage/ledtrig-netdev
+define KernelPackage/rtc-pt7c4338
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=LED NETDEV Trigger
-  KCONFIG:=CONFIG_LEDS_TRIGGER_NETDEV
-  FILES:=$(LINUX_DIR)/drivers/leds/ledtrig-netdev.ko
-  AUTOLOAD:=$(call AutoLoad,50,ledtrig-netdev)
+  TITLE:=Pericom PT7C4338 RTC support
+  $(call AddDepends/rtc,+kmod-i2c-core)
+  KCONFIG:=CONFIG_RTC_DRV_PT7C4338
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pt7c4338.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-pt7c4338)
 endef
 
-define KernelPackage/ledtrig-netdev/description
- Kernel module to drive LEDs based on network activity.
+define KernelPackage/rtc-pt7c4338/description
+ Kernel module for Pericom PT7C4338 i2c RTC chip.
 endef
 
-$(eval $(call KernelPackage,ledtrig-netdev))
+$(eval $(call KernelPackage,rtc-pt7c4338))
 
 
-define KernelPackage/lp
+define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Parallel port and line printer support
-  DEPENDS:=@BROKEN
-  KCONFIG:= \
-       CONFIG_PARPORT \
-       CONFIG_PRINTER \
-       CONFIG_PPDEV
-  FILES:= \
-       $(LINUX_DIR)/drivers/parport/parport.ko \
-       $(LINUX_DIR)/drivers/char/lp.ko \
-       $(LINUX_DIR)/drivers/char/ppdev.ko
-  AUTOLOAD:=$(call AutoLoad,50,parport lp)
+  TITLE:=MTD subsystem tests
+  KCONFIG:=CONFIG_MTD_TESTS
+  FILES:=\
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_nandecctest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_oobtest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_pagetest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_readtest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_speedtest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_stresstest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_subpagetest.ko \
+       $(LINUX_DIR)/drivers/mtd/tests/mtd_torturetest.ko
 endef
 
-$(eval $(call KernelPackage,lp))
+define KernelPackage/mtdtests/description
+ Kernel modules for MTD subsystem/driver testing.
+endef
 
+$(eval $(call KernelPackage,mtdtests))
 
-define KernelPackage/mmc
+
+define KernelPackage/nand
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=MMC/SD Card Support
-  KCONFIG:= \
-       CONFIG_MMC \
-       CONFIG_MMC_BLOCK \
-       CONFIG_MMC_DEBUG=n \
-       CONFIG_MMC_UNSAFE_RESUME=n \
-       CONFIG_MMC_BLOCK_BOUNCE=y \
-       CONFIG_MMC_SDHCI=n \
-       CONFIG_MMC_TIFM_SD=n \
-       CONFIG_MMC_WBSD=n \
-       CONFIG_SDIO_UART=n
+  TITLE:=NAND flash support
+  KCONFIG:=CONFIG_MTD_NAND \
+       CONFIG_MTD_NAND_IDS \
+       CONFIG_MTD_NAND_ECC
   FILES:= \
-       $(LINUX_DIR)/drivers/mmc/core/mmc_core.ko \
-       $(LINUX_DIR)/drivers/mmc/card/mmc_block.ko
-  AUTOLOAD:=$(call AutoLoad,90,mmc_core mmc_block,1)
+       $(LINUX_DIR)/drivers/mtd/nand/nand_ids.ko \
+       $(LINUX_DIR)/drivers/mtd/nand/nand_ecc.ko \
+       $(LINUX_DIR)/drivers/mtd/nand/nand.ko
+  AUTOLOAD:=$(call AutoLoad,20,nand_ids nand_ecc nand)
 endef
 
-define KernelPackage/mmc/description
- Kernel support for MMC/SD cards
+define KernelPackage/nand/description
+ Kernel module for NAND support.
 endef
 
-$(eval $(call KernelPackage,mmc))
+$(eval $(call KernelPackage,nand))
 
 
-define KernelPackage/mmc-atmelmci
+define KernelPackage/nandsim
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Amtel MMC Support
-  DEPENDS:=@TARGET_avr32 +kmod-mmc
-  KCONFIG:=CONFIG_MMC_ATMELMCI
-  FILES:=$(LINUX_DIR)/drivers/mmc/host/atmel-mci.ko
-  AUTOLOAD:=$(call AutoLoad,90,atmel-mci)
+  TITLE:=NAND simulator
+  DEPENDS:=+kmod-nand
+  KCONFIG:=CONFIG_MTD_NAND_NANDSIM
+  FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
 endef
 
-define KernelPackage/mmc-atmelmci/description
- Kernel support for  Atmel Multimedia Card Interface.
+define KernelPackage/nandsim/description
+ Kernel module for NAND flash simulation.
 endef
 
-$(eval $(call KernelPackage,mmc-atmelmci,1))
+$(eval $(call KernelPackage,nandsim))
 
-
-define KernelPackage/rfkill
+define KernelPackage/serial-8250
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=RF switch subsystem support
-  KCONFIG:= \
-    CONFIG_RFKILL \
-    CONFIG_RFKILL_INPUT=y \
-    CONFIG_RFKILL_LEDS=y
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.31)),1)
-  FILES:= \
-    $(LINUX_DIR)/net/rfkill/rfkill.ko
-  AUTOLOAD:=$(call AutoLoad,20,rfkill)
-else
-  FILES:= \
-    $(LINUX_DIR)/net/rfkill/rfkill.ko \
-    $(LINUX_DIR)/net/rfkill/rfkill-input.ko
-  AUTOLOAD:=$(call AutoLoad,20,rfkill rfkill-input)
-endif
-  $(call SetDepends/rfkill)
+  TITLE:=8250 UARTs
+  KCONFIG:= CONFIG_SERIAL_8250 \
+       CONFIG_SERIAL_8250_NR_UARTS=16 \
+       CONFIG_SERIAL_8250_RUNTIME_UARTS=16 \
+       CONFIG_SERIAL_8250_EXTENDED=y \
+       CONFIG_SERIAL_8250_MANY_PORTS=y \
+       CONFIG_SERIAL_8250_SHARE_IRQ=y \
+       CONFIG_SERIAL_8250_DETECT_IRQ=n \
+       CONFIG_SERIAL_8250_RSA=n
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250$(if $(call kernel_patchver_ge,3.7),_core).ko
 endef
 
-define KernelPackage/rfkill/description
-  Say Y here if you want to have control over RF switches
-  found on many WiFi and Bluetooth cards.
+define KernelPackage/serial-8250/description
+ Kernel module for 8250 UART based serial ports.
 endef
 
-$(eval $(call KernelPackage,rfkill))
+$(eval $(call KernelPackage,serial-8250))
 
 
-define KernelPackage/softdog
+define KernelPackage/regmap
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Software watchdog driver
-  KCONFIG:=CONFIG_SOFT_WATCHDOG
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/softdog.ko
-  AUTOLOAD:=$(call AutoLoad,50,softdog)
+  TITLE:=Generic register map support
+  DEPENDS:=+kmod-lib-lzo +kmod-i2c-core
+  KCONFIG:=CONFIG_REGMAP \
+          CONFIG_REGMAP_SPI \
+          CONFIG_REGMAP_I2C \
+          CONFIG_SPI=y
+  FILES:= \
+       $(LINUX_DIR)/drivers/base/regmap/regmap-core.ko \
+       $(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
+       $(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko
+  AUTOLOAD:=$(call AutoLoad,21,regmap-core regmap-i2c regmap-spi)
 endef
 
-define KernelPackage/softdog/description
- Software watchdog driver
+define KernelPackage/regmap/description
+  Generic register map support
 endef
 
-$(eval $(call KernelPackage,softdog))
-
+$(eval $(call KernelPackage,regmap))
 
-define KernelPackage/ssb
+define KernelPackage/ikconfig
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Silicon Sonics Backplane glue code
-  DEPENDS:=@PCI_SUPPORT @!TARGET_brcm47xx @!TARGET_brcm63xx
-  KCONFIG:=\
-       CONFIG_SSB \
-       CONFIG_SSB_B43_PCI_BRIDGE=y \
-       CONFIG_SSB_DRIVER_MIPS=n \
-       CONFIG_SSB_DRIVER_PCICORE=y \
-       CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y \
-       CONFIG_SSB_PCIHOST=y \
-       CONFIG_SSB_PCIHOST_POSSIBLE=y \
-       CONFIG_SSB_POSSIBLE=y \
-       CONFIG_SSB_SPROM=y \
-       CONFIG_SSB_SILENT=y
-  FILES:=$(LINUX_DIR)/drivers/ssb/ssb.ko
-  AUTOLOAD:=$(call AutoLoad,29,ssb)
+  TITLE:=Kernel configuration via /proc/config.gz
+  KCONFIG:=CONFIG_IKCONFIG \
+          CONFIG_IKCONFIG_PROC=y
+  FILES:=$(LINUX_DIR)/kernel/configs.ko
+  AUTOLOAD:=$(call AutoLoad,70,configs)
 endef
 
-define KernelPackage/ssb/description
-  Silicon Sonics Backplane glue code.
+define KernelPackage/ikconfig/description
+       Kernel configuration via /proc/config.gz
 endef
 
-$(eval $(call KernelPackage,ssb))
+$(eval $(call KernelPackage,ikconfig))
 
 
-define KernelPackage/textsearch
-SUBMENU:=$(OTHER_MENU)
-  TITLE:=Textsearch support is selected if needed
+define KernelPackage/zram
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=ZRAM
+  DEPENDS:=@!LINUX_3_3 +kmod-lib-lzo
   KCONFIG:= \
-    CONFIG_TEXTSEARCH=y \
-    CONFIG_TEXTSEARCH_KMP \
-    CONFIG_TEXTSEARCH_BM \
-    CONFIG_TEXTSEARCH_FSM
+       CONFIG_ZSMALLOC \
+       CONFIG_ZRAM \
+       CONFIG_ZRAM_DEBUG=n
   FILES:= \
-    $(LINUX_DIR)/lib/ts_kmp.ko \
-    $(LINUX_DIR)/lib/ts_bm.ko \
-    $(LINUX_DIR)/lib/ts_fsm.ko
-  AUTOLOAD:=$(call AutoLoad,20,ts_kmp ts_bm ts_fsm)
+       $(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko \
+       $(LINUX_DIR)/drivers/staging/zram/zram.ko
+  AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
 endef
 
-$(eval $(call KernelPackage,textsearch))
+define KernelPackage/zram/description
+ Compressed RAM block device support
+endef
+
+$(eval $(call KernelPackage,zram))
 
 
-define KernelPackage/wdt-geode
+define KernelPackage/mvsdio
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Geode/LX Watchdog timer
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_GEODE_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/geodewdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,geodewdt)
+  TITLE:=Marvell SDIO support
+  DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu +kmod-mmc
+  KCONFIG:=CONFIG_MMC_MVSDIO
+  FILES:=$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+  AUTOLOAD:=$(call AutoLoad,91,mvsdio)
 endef
 
-define KernelPackage/wdt-geode/description
-  Kernel module for Geode watchdog timer.
+define KernelPacakge/mvsdio/description
+  Kernel support for the Marvell SDIO controller
 endef
 
-$(eval $(call KernelPackage,wdt-geode))
+$(eval $(call KernelPackage,mvsdio))
 
 
-define KernelPackage/wdt-sc520
+define KernelPackage/pps
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi SC520 Watchdog support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_SC520_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sc520_wdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,sc520_wdt)
+  TITLE:=PPS support
+  KCONFIG:=CONFIG_PPS
+  FILES:=$(LINUX_DIR)/drivers/pps/pps_core.ko
+  AUTOLOAD:=$(call AutoLoad,20,pps_core)
 endef
 
-define KernelPackage/wdt-sc520/description
-  Kernel module for SC520 Watchdog
+define KernelPacakge/pps/description
+  PPS (Pulse Per Second) is a special pulse provided by some GPS
+  antennae. Userland can use it to get a high-precision time
+  reference.
 endef
 
-$(eval $(call KernelPackage,wdt-sc520))
+$(eval $(call KernelPackage,pps))
 
 
-define KernelPackage/wdt-scx200
+define KernelPackage/ptp
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi SCX200 Watchdog support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_SCx200_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/scx200_wdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,scx200_wdt)
+  TITLE:=PTP clock support
+  DEPENDS:=+kmod-pps
+  KCONFIG:=CONFIG_PTP_1588_CLOCK
+  FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
+  AUTOLOAD:=$(call AutoLoad,25,ptp)
 endef
 
-define KernelPackage/wdt-scx200/description
- Kernel module for SCX200 Watchdog
+define KernelPacakge/ptp/description
+  The IEEE 1588 standard defines a method to precisely
+  synchronize distributed clocks over Ethernet networks.
 endef
 
-$(eval $(call KernelPackage,wdt-scx200))
+$(eval $(call KernelPackage,ptp))
 
 
-define KernelPackage/pwm-gpio
+define KernelPackage/ptp-gianfar
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=PWM over GPIO
-  KCONFIG:=CONFIG_GENERIC_PWM \
-               CONFIG_GPIO_PWM
-  FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.ko
-  AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
+  TITLE:=Freescale Gianfar PTP support
+  DEPENDS:=@TARGET_mpc85xx +kmod-gianfar +kmod-ptp
+  KCONFIG:=CONFIG_PTP_1588_CLOCK_GIANFAR
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/freescale/gianfar_ptp.ko
+  AUTOLOAD:=$(call AutoLoad,51,gianfar_ptp)
 endef
 
-define KernelPackage/pwm-gpio/description
- Kernel module to models a single-channel PWM device using a timer and a GPIO pin
+define KernelPacakge/ptp-gianfar/description
+  Kernel module for IEEE 1588 support for Freescale
+  Gianfar Ethernet drivers.
 endef
 
-$(eval $(call KernelPackage,pwm-gpio))
+$(eval $(call KernelPackage,ptp-gianfar))