kernel: add kmod-mcp23s08 package
[openwrt/staging/yousong.git] / package / kernel / modules / other.mk
index 68b8e3c881ba99604d762e85a210149cd37042fc..f282014a30637a05e694654185152b403e76bc49 100644 (file)
@@ -70,22 +70,6 @@ endef
 $(eval $(call KernelPackage,bluetooth-hci-h4p))
 
 
-define KernelPackage/cpu-msr
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=x86 CPU MSR support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_X86_MSR
-  FILES:=$(LINUX_DIR)/arch/x86/kernel/msr.ko
-  AUTOLOAD:=$(call AutoLoad,20,msr)
-endef
-
-define KernelPackage/cpu-msr/description
- Kernel module for Model Specific Registers support in x86 CPUs
-endef
-
-$(eval $(call KernelPackage,cpu-msr))
-
-
 define KernelPackage/eeprom-93cx6
   SUBMENU:=$(OTHER_MENU)
   TITLE:=EEPROM 93CX6 support
@@ -132,22 +116,6 @@ endef
 $(eval $(call KernelPackage,eeprom-at25))
 
 
-define KernelPackage/gpio-cs5535-new
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
-  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
-  KCONFIG:=CONFIG_GPIO_CS5535
-  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cs5535.ko
-  AUTOLOAD:=$(call AutoLoad,50,gpio-cs5535)
-endef
-
-define KernelPackage/gpio-cs5535-new/description
- This package contains the new AMD CS5535/CS5536 GPIO driver
-endef
-
-$(eval $(call KernelPackage,gpio-cs5535-new))
-
-
 define KernelPackage/gpio-dev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Generic GPIO char device support
@@ -164,57 +132,25 @@ endef
 $(eval $(call KernelPackage,gpio-dev))
 
 
-define KernelPackage/gpio-nsc
+define KernelPackage/gpio-mcp23s08
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi GPIO support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_NSC_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/nsc_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,40,nsc_gpio)
-endef
-
-define KernelPackage/gpio-nsc/description
- Kernel module for Natsemi GPIO
-endef
-
-$(eval $(call KernelPackage,gpio-nsc))
-
-
-define KernelPackage/gpio-pc8736x
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=PC8736x GPIO support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_PC8736x_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/pc8736x_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,40,pc8736x_gpio)
+  TITLE:=Microchip MCP23xxx I/O expander
+  DEPENDS:=@GPIO_SUPPORT
+  KCONFIG:=CONFIG_GPIO_MCP23S08
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-mcp23s08.ko
+  AUTOLOAD:=$(call AutoLoad,40,gpio-mcp23s08)
 endef
 
-define KernelPackage/gpio-pc8736x/description
- Kernel module for PC8736x GPIO
+define KernelPackage/gpio-mcp23s08/description
+  Kernel module for Microchip MCP23xxx SPI/I2C I/O expander
 endef
 
-$(eval $(call KernelPackage,gpio-pc8736x))
-
-
-define KernelPackage/gpio-scx200
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi SCX200 GPIO support
-  DEPENDS:=@TARGET_x86 +kmod-gpio-nsc
-  KCONFIG:=CONFIG_SCx200_GPIO
-  FILES:=$(LINUX_DIR)/drivers/char/scx200_gpio.ko
-  AUTOLOAD:=$(call AutoLoad,50,scx200_gpio)
-endef
+$(eval $(call KernelPackage,gpio-mcp23s08))
 
-define KernelPackage/gpio-scx200/description
- Kernel module for SCX200 GPIO
-endef
-
-$(eval $(call KernelPackage,gpio-scx200))
 
 define KernelPackage/gpio-nxp-74hc164
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NXP 74HC164 GPIO expander support
-  DEPENDS:=@TARGET_brcm63xx
   KCONFIG:=CONFIG_GPIO_NXP_74HC164
   FILES:=$(LINUX_DIR)/drivers/gpio/nxp_74hc164.ko
   AUTOLOAD:=$(call AutoLoad,99,nxp_74hc164)
@@ -226,157 +162,20 @@ endef
 
 $(eval $(call KernelPackage,gpio-nxp-74hc164))
 
-define KernelPackage/hid
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=HID Devices
-  KCONFIG:=CONFIG_HID
-  FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
-  AUTOLOAD:=$(call AutoLoad,61,hid)
-  $(call AddDepends/input,+kmod-input-evdev)
-endef
-
-define KernelPackage/hid/description
- Kernel modules for HID devices
-endef
-
-$(eval $(call KernelPackage,hid))
-
-
-define KernelPackage/input-core
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Input device core
-  KCONFIG:=CONFIG_INPUT
-  FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
-  AUTOLOAD:=$(call AutoLoad,19,input-core)
-endef
-
-define KernelPackage/input-core/description
- Kernel modules for support of input device
-endef
-
-$(eval $(call KernelPackage,input-core))
-
-
-define KernelPackage/input-evdev
+define KernelPackage/gpio-pcf857x
   SUBMENU:=$(OTHER_MENU)
-  TITLE:=Input event device
-  KCONFIG:=CONFIG_INPUT_EVDEV
-  FILES:=$(LINUX_DIR)/drivers/input/evdev.ko
-  AUTOLOAD:=$(call AutoLoad,60,evdev)
-  $(call AddDepends/input)
+  DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+  TITLE:=PCX857x, PCA967x and MAX732X I2C GPIO expanders
+  KCONFIG:=CONFIG_GPIO_PCF857X
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-pcf857x.ko
+  AUTOLOAD:=$(call AutoLoad,55,gpio-pcf857x)
 endef
 
-define KernelPackage/input-evdev/description
Kernel modules for support of input device events
+define KernelPackage/gpio-pcf857x/description
 Kernel module for PCF857x, PCA{85,96}7x, and MAX732[89] I2C GPIO expanders
 endef
 
-$(eval $(call KernelPackage,input-evdev))
-
-
-define KernelPackage/input-gpio-buttons
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Polled GPIO buttons input device
-  DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
-  KCONFIG:= \
-       CONFIG_INPUT_GPIO_BUTTONS \
-       CONFIG_INPUT_MISC=y
-  FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_buttons)
-endef
-
-define KernelPackage/input-gpio-buttons/description
- Kernel module for support polled GPIO buttons input device
-endef
-
-$(eval $(call KernelPackage,input-gpio-buttons))
-
-
-define KernelPackage/input-gpio-keys
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=GPIO key support
-  DEPENDS:= @GPIO_SUPPORT
-  KCONFIG:= \
-       CONFIG_KEYBOARD_GPIO \
-       CONFIG_INPUT_KEYBOARD=y
-  FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
-  AUTOLOAD:=$(call AutoLoad,60,gpio_keys)
-  $(call AddDepends/input)
-endef
-
-define KernelPackage/input-gpio-keys/description
- This driver implements support for buttons connected
- to GPIO pins of various CPUs (and some other chips).
-endef
-
-$(eval $(call KernelPackage,input-gpio-keys))
-
-
-define KernelPackage/input-gpio-keys-polled
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Polled GPIO key support
-  DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
-  KCONFIG:= \
-       CONFIG_KEYBOARD_GPIO_POLLED \
-       CONFIG_INPUT_KEYBOARD=y
-  FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
-  AUTOLOAD:=$(call AutoLoad,62,gpio_keys_polled)
-  $(call AddDepends/input)
-endef
-
-define KernelPackage/input-gpio-keys-polled/description
- Kernel module for support polled GPIO keys input device
-endef
-
-$(eval $(call KernelPackage,input-gpio-keys-polled))
-
-
-define KernelPackage/input-gpio-encoder
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=GPIO rotay encoder
-  KCONFIG:=CONFIG_INPUT_GPIO_ROTARY_ENCODER
-  FILES:=$(LINUX_DIR)/drivers/input/misc/rotary_encoder.ko
-  AUTOLOAD:=$(call AutoLoad,62,rotary_encoder)
-  $(call AddDepends/input,@GPIO_SUPPORT)
-endef
-
-define KernelPackage/gpio-encoder/description
- Kernel module to use rotary encoders connected to GPIO pins
-endef
-
-$(eval $(call KernelPackage,input-gpio-encoder))
-
-
-define KernelPackage/input-joydev
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Joystick device support
-  KCONFIG:=CONFIG_INPUT_JOYDEV
-  FILES:=$(LINUX_DIR)/drivers/input/joydev.ko
-  AUTOLOAD:=$(call AutoLoad,62,joydev)
-  $(call AddDepends/input)
-endef
-
-define KernelPackage/input-joydev/description
-  Kernel module for joystick support
-endef
-
-$(eval $(call KernelPackage,input-joydev))
-
-
-define KernelPackage/input-polldev
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Polled Input device support
-  KCONFIG:=CONFIG_INPUT_POLLDEV
-  FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-  AUTOLOAD:=$(call AutoLoad,20,input-polldev)
-  $(call AddDepends/input)
-endef
-
-define KernelPackage/input-polldev/description
- Kernel module for support of polled input devices
-endef
-
-$(eval $(call KernelPackage,input-polldev))
-
+$(eval $(call KernelPackage,gpio-pcf857x))
 
 define KernelPackage/lp
   SUBMENU:=$(OTHER_MENU)
@@ -422,22 +221,6 @@ endef
 $(eval $(call KernelPackage,mmc))
 
 
-define KernelPackage/mmc-atmelmci
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Amtel MMC Support
-  DEPENDS:=@TARGET_avr32 +kmod-mmc
-  KCONFIG:=CONFIG_MMC_ATMELMCI
-  FILES:=$(LINUX_DIR)/drivers/mmc/host/atmel-mci.ko
-  AUTOLOAD:=$(call AutoLoad,90,atmel-mci)
-endef
-
-define KernelPackage/mmc-atmelmci/description
- Kernel support for  Atmel Multimedia Card Interface.
-endef
-
-$(eval $(call KernelPackage,mmc-atmelmci,1))
-
-
 define KernelPackage/oprofile
   SUBMENU:=$(OTHER_MENU)
   TITLE:=OProfile profiling support
@@ -459,7 +242,8 @@ define KernelPackage/rfkill
   KCONFIG:= \
     CONFIG_RFKILL \
     CONFIG_RFKILL_INPUT=y \
-    CONFIG_RFKILL_LEDS=y
+    CONFIG_RFKILL_LEDS=y \
+    CONFIG_RFKILL_GPIO=y
   FILES:= \
     $(LINUX_DIR)/net/rfkill/rfkill.ko
   AUTOLOAD:=$(call AutoLoad,20,rfkill)
@@ -527,6 +311,7 @@ define KernelPackage/bcma
        CONFIG_BCMA_HOST_PCI=y \
        CONFIG_BCMA_DRIVER_MIPS=n \
        CONFIG_BCMA_DRIVER_PCI_HOSTMODE=n \
+       CONFIG_BCMA_DRIVER_GMAC_CMN=n \
        CONFIG_BCMA_DEBUG=n
   FILES:=$(LINUX_DIR)/drivers/bcma/bcma.ko
   AUTOLOAD:=$(call AutoLoad,29,bcma)
@@ -539,72 +324,6 @@ endef
 $(eval $(call KernelPackage,bcma))
 
 
-define KernelPackage/wdt-geode
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Geode/LX Watchdog timer
-  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
-  KCONFIG:=CONFIG_GEODE_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/geodewdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,geodewdt)
-endef
-
-define KernelPackage/wdt-geode/description
-  Kernel module for Geode watchdog timer.
-endef
-
-$(eval $(call KernelPackage,wdt-geode))
-
-
-define KernelPackage/cs5535-clockevt
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CS5535/CS5536 high-res timer (MFGPT) events
-  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfgpt
-  KCONFIG:=CONFIG_CS5535_CLOCK_EVENT_SRC
-  FILES:=$(LINUX_DIR)/drivers/clocksource/cs5535-clockevt.ko
-  AUTOLOAD:=$(call AutoLoad,50,cs5535-clockevt)
-endef
-
-define KernelPackage/cs5535-clockevt/description
-  Kernel module for CS5535/6 high-res clock event source
-endef
-
-$(eval $(call KernelPackage,cs5535-clockevt))
-
-
-define KernelPackage/cs5535-mfgpt
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CS5535/6 Multifunction General Purpose Timer
-  DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
-  KCONFIG:=CONFIG_CS5535_MFGPT
-  FILES:=$(LINUX_DIR)/drivers/misc/cs5535-mfgpt.ko
-  AUTOLOAD:=$(call AutoLoad,45,cs5535-mfgpt)
-endef
-
-define KernelPackage/cs5535-mfgpt/description
-  Kernel module for CS5535/6 multifunction general purpose timer.
-endef
-
-$(eval $(call KernelPackage,cs5535-mfgpt))
-
-
-define KernelPackage/cs5535-mfd
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=CS5535/6 Multifunction General Purpose Driver
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_MFD_CS5535
-  FILES:= \
-       $(LINUX_DIR)/drivers/mfd/mfd-core.ko \
-       $(LINUX_DIR)/drivers/mfd/cs5535-mfd.ko
-  AUTOLOAD:=$(call AutoLoad,44,mfd-core cs5535-mfd)
-endef
-
-define KernelPackage/cs5535-mfd/description
-  Core driver for CS5535/CS5536 MFD functions.
-endef
-
-$(eval $(call KernelPackage,cs5535-mfd))
-
-
 define KernelPackage/wdt-omap
   SUBMENU:=$(OTHER_MENU)
   TITLE:=OMAP Watchdog timer
@@ -624,67 +343,19 @@ $(eval $(call KernelPackage,wdt-omap))
 define KernelPackage/wdt-orion
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell Orion Watchdog timer
-  DEPENDS:=@TARGET_orion
+  DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
   KCONFIG:=CONFIG_ORION_WATCHDOG
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
   AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
 endef
 
 define KernelPackage/wdt-orion/description
-  Kernel module for Marvell orion watchdog timer.
+  Kernel module for Marvell Orion, Kirkwood and Armada XP/370 watchdog timer.
 endef
 
 $(eval $(call KernelPackage,wdt-orion))
 
 
-define KernelPackage/wdt-sc520
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi SC520 Watchdog support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_SC520_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sc520_wdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,sc520_wdt)
-endef
-
-define KernelPackage/wdt-sc520/description
-  Kernel module for SC520 Watchdog
-endef
-
-$(eval $(call KernelPackage,wdt-sc520))
-
-
-define KernelPackage/wdt-scx200
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Natsemi SCX200 Watchdog support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_SCx200_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/scx200_wdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,scx200_wdt)
-endef
-
-define KernelPackage/wdt-scx200/description
- Kernel module for SCX200 Watchdog
-endef
-
-$(eval $(call KernelPackage,wdt-scx200))
-
-
-define KernelPackage/wdt-ath79
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Atheros AR7XXX/AR9XXX watchdog timer
-  DEPENDS:=@TARGET_ar71xx
-  KCONFIG:=CONFIG_ATH79_WDT
-  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/ath79_wdt.ko
-  AUTOLOAD:=$(call AutoLoad,50,ath79_wdt)
-endef
-
-define KernelPackage/wdt-ath79/description
-  Kernel module for AR7XXX/AR9XXX watchdog timer.
-endef
-
-$(eval $(call KernelPackage,wdt-ath79))
-
-
 define KernelPackage/booke-wdt
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PowerPC Book-E Watchdog Timer
@@ -732,11 +403,28 @@ endef
 $(eval $(call KernelPackage,pwm-gpio))
 
 
+define KernelPackage/rtc-isl1208
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Intersil ISL1208 RTC support
+  $(call AddDepends/rtc)
+  DEPENDS+=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_ISL1208
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-isl1208.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-isl1208)
+endef
+
+define KernelPackage/rtc-isl1208/description
+ Kernel module for Intersil ISL1208 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-isl1208))
+
+
 define KernelPackage/rtc-marvell
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell SoC built-in RTC support
   $(call AddDepends/rtc)
-  DEPENDS+=@TARGET_kirkwood||TARGET_orion
+  DEPENDS+=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu
   KCONFIG:=CONFIG_RTC_DRV_MV
   FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
   AUTOLOAD:=$(call AutoLoad,60,rtc-mv)
@@ -795,22 +483,6 @@ endef
 
 $(eval $(call KernelPackage,rtc-pt7c4338))
 
-define KernelPackage/n810bm
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Nokia N810 battery management driver
-  DEPENDS:=@TARGET_omap24xx
-  KCONFIG:=CONFIG_N810BM
-  FILES:=$(LINUX_DIR)/drivers/cbus/n810bm.ko
-  AUTOLOAD:=$(call AutoLoad,01,n810bm)
-endef
-
-define KernelPackage/n810bm/description
-  Nokia N810 battery management driver.
-  Controls battery power management and battery charging.
-endef
-
-$(eval $(call KernelPackage,n810bm))
-
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)
@@ -837,7 +509,6 @@ $(eval $(call KernelPackage,mtdtests))
 define KernelPackage/nand
   SUBMENU:=$(OTHER_MENU)
   TITLE:=NAND flash support
-  DEPENDS:=@!LINUX_2_6_39
   KCONFIG:=CONFIG_MTD_NAND \
        CONFIG_MTD_NAND_IDS \
        CONFIG_MTD_NAND_ECC
@@ -880,7 +551,7 @@ define KernelPackage/serial-8250
        CONFIG_SERIAL_8250_SHARE_IRQ=y \
        CONFIG_SERIAL_8250_DETECT_IRQ=n \
        CONFIG_SERIAL_8250_RSA=n
-  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250$(if $(call kernel_patchver_ge,3.7),_core).ko
 endef
 
 define KernelPackage/serial-8250/description
@@ -890,30 +561,19 @@ endef
 $(eval $(call KernelPackage,serial-8250))
 
 
-define KernelPackage/acpi-button
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=ACPI Button Support
-  DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
-  KCONFIG:=CONFIG_ACPI_BUTTON
-  FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
-  AUTOLOAD:=$(call AutoLoad,06,button)
-endef
-
-define KernelPackage/acpi-button/description
- Kernel module for ACPI Button support
-endef
-
-$(eval $(call KernelPackage,acpi-button))
-
 define KernelPackage/regmap
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Generic register map support
-  KCONFIG:=CONFIG_REGMAP=y \
+  DEPENDS:=+kmod-lib-lzo +kmod-i2c-core
+  KCONFIG:=CONFIG_REGMAP \
           CONFIG_REGMAP_SPI \
-          CONFIG_REGMAP_I2C
-  FILES:=$(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
-        $(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko
-  AUTOLOAD:=$(call AutoLoad,10,regmap-i2c regmap-spi)
+          CONFIG_REGMAP_I2C \
+          CONFIG_SPI=y
+  FILES:= \
+       $(LINUX_DIR)/drivers/base/regmap/regmap-core.ko \
+       $(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
+       $(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko
+  AUTOLOAD:=$(call AutoLoad,21,regmap-core regmap-i2c regmap-spi)
 endef
 
 define KernelPackage/regmap/description
@@ -921,3 +581,106 @@ define KernelPackage/regmap/description
 endef
 
 $(eval $(call KernelPackage,regmap))
+
+define KernelPackage/ikconfig
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Kernel configuration via /proc/config.gz
+  KCONFIG:=CONFIG_IKCONFIG \
+          CONFIG_IKCONFIG_PROC=y
+  FILES:=$(LINUX_DIR)/kernel/configs.ko
+  AUTOLOAD:=$(call AutoLoad,70,configs)
+endef
+
+define KernelPackage/ikconfig/description
+       Kernel configuration via /proc/config.gz
+endef
+
+$(eval $(call KernelPackage,ikconfig))
+
+
+define KernelPackage/zram
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=ZRAM
+  DEPENDS:=@!LINUX_3_3 +kmod-lib-lzo
+  KCONFIG:= \
+       CONFIG_ZSMALLOC \
+       CONFIG_ZRAM \
+       CONFIG_ZRAM_DEBUG=n
+  FILES:= \
+       $(LINUX_DIR)/drivers/staging/zsmalloc/zsmalloc.ko \
+       $(LINUX_DIR)/drivers/staging/zram/zram.ko
+  AUTOLOAD:=$(call AutoLoad,20,zsmalloc zram)
+endef
+
+define KernelPackage/zram/description
+ Compressed RAM block device support
+endef
+
+$(eval $(call KernelPackage,zram))
+
+
+define KernelPackage/mvsdio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Marvell SDIO support
+  DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu +kmod-mmc
+  KCONFIG:=CONFIG_MMC_MVSDIO
+  FILES:=$(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+  AUTOLOAD:=$(call AutoLoad,91,mvsdio)
+endef
+
+define KernelPacakge/mvsdio/description
+  Kernel support for the Marvell SDIO controller
+endef
+
+$(eval $(call KernelPackage,mvsdio))
+
+
+define KernelPackage/pps
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PPS support
+  KCONFIG:=CONFIG_PPS
+  FILES:=$(LINUX_DIR)/drivers/pps/pps_core.ko
+  AUTOLOAD:=$(call AutoLoad,20,pps_core)
+endef
+
+define KernelPacakge/pps/description
+  PPS (Pulse Per Second) is a special pulse provided by some GPS
+  antennae. Userland can use it to get a high-precision time
+  reference.
+endef
+
+$(eval $(call KernelPackage,pps))
+
+
+define KernelPackage/ptp
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PTP clock support
+  DEPENDS:=+kmod-pps
+  KCONFIG:=CONFIG_PTP_1588_CLOCK
+  FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
+  AUTOLOAD:=$(call AutoLoad,25,ptp)
+endef
+
+define KernelPacakge/ptp/description
+  The IEEE 1588 standard defines a method to precisely
+  synchronize distributed clocks over Ethernet networks.
+endef
+
+$(eval $(call KernelPackage,ptp))
+
+
+define KernelPackage/ptp-gianfar
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Freescale Gianfar PTP support
+  DEPENDS:=@TARGET_mpc85xx +kmod-gianfar +kmod-ptp
+  KCONFIG:=CONFIG_PTP_1588_CLOCK_GIANFAR
+  FILES:=$(LINUX_DIR)/drivers/net/ethernet/freescale/gianfar_ptp.ko
+  AUTOLOAD:=$(call AutoLoad,51,gianfar_ptp)
+endef
+
+define KernelPacakge/ptp-gianfar/description
+  Kernel module for IEEE 1588 support for Freescale
+  Gianfar Ethernet drivers.
+endef
+
+$(eval $(call KernelPackage,ptp-gianfar))