mbedtls: add --function-sections and --data-sections to CFLAGS
[openwrt/staging/yousong.git] / package / libs / mbedtls / Makefile
index 12b97da243d3a29af18d8141187c8173476cbf3e..a7d698c4fc53ca511a9ef1d2f9c27e7bfeefca71 100644 (file)
@@ -48,6 +48,8 @@ endef
 
 PKG_INSTALL:=1
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
 CMAKE_OPTIONS += \
        -DCMAKE_BUILD_TYPE:String="Release" \
        -DUSE_SHARED_MBEDTLS_LIBRARY:Bool=ON \