mac80211: update to wireless-testing+wireless-2.6 from 2010-01-13
[openwrt/staging/yousong.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index da07a76bd6ea461de000175572da9922ed9050a4..222cd9b544c1238c854518f348714a27fffd69b3 100644 (file)
@@ -1,7 +1,7 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -16,7 +16,7 @@ include $(KLIB_BUILD)/.config
- endif
+@@ -73,7 +73,7 @@ endif # build check
+ endif # kernel Makefile check
  
  # These both are needed by compat-wireless || compat-bluetooth so enable them
 - CONFIG_COMPAT_RFKILL=y
@@ -9,7 +9,7 @@
  
  ifeq ($(CONFIG_MAC80211),y)
  $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-@@ -463,8 +463,8 @@ endif
+@@ -474,8 +474,8 @@ endif
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
  ifdef CONFIG_COMPAT_KERNEL_31