net/utils/tcpdump: update to 4.8.1
[openwrt/staging/yousong.git] / package / network / utils / tcpdump / Makefile
index df1ee3c31bd241734533ad56914add7aab3d14df..dc6591bf719bf32982fd3613f564652780de74fc 100644 (file)
@@ -8,20 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tcpdump
-PKG_VERSION:=4.2.1
-PKG_RELEASE:=2
+PKG_VERSION:=4.8.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tcpdump.org/release/ \
-       http://ftp.gwdg.de/pub/misc/tcpdump/ \
-       http://www.at.tcpdump.org/ \
-       http://www.br.tcpdump.org/
-PKG_MD5SUM:=c202878c6db054767b52651041b9e60e
+       http://www.at.tcpdump.org/
+PKG_MD5SUM:=32f57943649f276e09236ba66622bb0c
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=BSD-3-Clause
 
 PKG_INSTALL:=1
 
@@ -54,6 +53,9 @@ CONFIGURE_ARGS += \
        --enable-ipv6
 endif
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
 CONFIGURE_VARS += \
        BUILD_CC="$(TARGET_CC)" \
        HOSTCC="$(HOSTCC)" \