major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/yousong.git] / package / util-linux / Makefile
index e112d0125eefdd05a7f217dc8e1c26206822d6f9..2ea4c7e564fb402aec9b440125030f3de286f4ca 100644 (file)
@@ -10,13 +10,10 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.12r
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,42 +21,75 @@ include $(INCLUDE_DIR)/package.mk
 define Package/util-linux/Default
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=@!TARGET_etrax
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
 define Package/fdisk
-  $(call Package/util-linux/Default)
+$(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
-  DESCRIPTION:=\
-       This package contains an utility for managing disk partition tables.
-  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
+endef
+
+define Package/fdisk/description
+ This package contains a utility for managing disk partition tables.
+endef
+
+define Package/cfdisk
+$(call Package/util-linux/Default)
+  TITLE:=Partition table manipulation utility
+  DEPENDS:= +libncurses
+endef
+
+define Package/cfdisk/description
+ This package contains a utility for managing disk partition tables.
 endef
 
 define Package/losetup
-  $(call Package/util-linux/Default)
+$(call Package/util-linux/Default)
   TITLE:=Loopback devices setup and control utility
-  DESCRIPTION:=\
-       This package contains an utility for managing loopback devices.
+endef
+
+define Package/losetup/description
+ This package contains a utility for managing loopback devices.
 endef
 
 define Package/swap-utils
-  $(call Package/util-linux/Default)
+$(call Package/util-linux/Default)
   TITLE:=Swap space management utilities
-  DESCRIPTION:=\
-       This package contains a collection of tools for managing swap space: \\\
-       - mkswap\\\
-       - swapon\\\
-       - swapoff
 endef
 
-TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
+define Package/swap-utils/description
+ This package contains a collection of tools for managing swap space: 
+ - mkswap
+ - swapon
+ - swapoff
+endef
+
+define Package/hwclock
+$(call Package/util-linux/Default)
+  TITLE:=Utilities for managing the hardware clock
+endef
+
+define Package/hwclock/description
+ This package contains a utility for managing the hardware clock.
+endef
+
+define Build/Configure
+       # this is NOT GNU configure!
+       ( cd $(PKG_BUILD_DIR); \
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               ./configure \
+       );
+endef
+
 define Build/Compile
-       $(call Build/Compile/Default, \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                OPT="$(TARGET_CFLAGS)" \
                INSTALLSUID="install -m 4755" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Package/Template
@@ -75,6 +105,10 @@ define Package/fdisk/install
        $(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
 endef
 
+define Package/cfdisk/install
+       $(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
+endef
+
 define Package/losetup/install
        $(call Package/Template,sbin/losetup,$(1)/usr/sbin)
 endef
@@ -85,6 +119,12 @@ define Package/swap-utils/install
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
 
+define Package/hwclock/install
+       $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
+endef
+
 $(eval $(call BuildPackage,fdisk))
+$(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))