get rid of $Id$ - it has never helped us and it has broken too many patches ;)
[openwrt/staging/yousong.git] / package / wpa_supplicant / Makefile
index 4c8347fff1c645438ee871386a0341c52fe490eb..0ad2ff31f8975f31fc0344f61d36a165b8dc8fc2 100644 (file)
@@ -1,21 +1,22 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
-PKG_VERSION:=0.6.3
-PKG_RELEASE:=1
-PKG_MD5SUM:=9e7b99da67c47d81121368c6d580d069
+PKG_VERSION:=0.6.9
+PKG_RELEASE:=2
+PKG_MD5SUM:=0efb8fcedf0a8acf6f423dfdb0658fdd
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
+PKG_BUILD_DEPENDS:=PACKAGE_kmod-madwifi:madwifi
+
 include $(INCLUDE_DIR)/package.mk
 STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(call confvar,CONFIG_PACKAGE_kmod-madwifi CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK)
 
@@ -23,6 +24,7 @@ define Package/wpa-supplicant
   SECTION:=net
   CATEGORY:=Network
   TITLE:=WPA Supplicant
+  DEPENDS:=$(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),+libopenssl)
   URL:=http://hostap.epitest.fi/wpa_supplicant/
 endef
 
@@ -31,16 +33,9 @@ define Package/wpa-supplicant/Description
 endef
 
 define Package/wpa-supplicant/config
-  config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
-       bool "Disable timestamp check"
-       depends PACKAGE_wpa-supplicant
-       default n
-       help
-               This disables the timestamp check for certificates in wpa_supplicant
-               Useful for devices without RTC that cannot reliably get the real date/time
+       source "$(SOURCE)/Config.in"
 endef
 
-
 define Package/wpa-cli
   SECTION:=net
   CATEGORY:=Network
@@ -49,7 +44,7 @@ define Package/wpa-cli
 endef
 
 define Package/wpa-cli/Description
- WPA Supplicant control utility 
+ WPA Supplicant control utility
 endef
 
 CONFIG=$(firstword $(wildcard ./files/config.$(BOARD) ./files/config.$(ARCH) ./config))
@@ -58,6 +53,7 @@ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/madwifi $(if $(CONFIG_WPA_SUPPLICA
 define Build/Configure
        cp $(CONFIG) $(PKG_BUILD_DIR)/wpa_supplicant/.config
        $(if $(CONFIG_PACKAGE_kmod-madwifi),,$(SED) 's,^CONFIG_DRIVER_MADWIFI,#CONFIG_DRIVER_MADWIFI,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
+       $(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),$(SED) 's|^CONFIG_TLS.*|CONFIG_TLS=openssl|g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
 endef
 
 define Build/Compile
@@ -78,11 +74,13 @@ define Package/wpa-supplicant/install
                $(PKG_BUILD_DIR)/wpa_supplicant/wpa_supplicant \
                $(PKG_BUILD_DIR)/wpa_supplicant/wpa_passphrase \
                $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/wpa_supplicant.sh $(1)/lib/wifi/wpa_supplicant.sh
 endef
 
 define Package/wpa-cli/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/wpa_cli $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/wpa_supplicant/wpa_cli $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wpa-supplicant))