package/busybox: include an upstream patch
[openwrt/staging/yousong.git] / rules.mk
index 49044c8cfbf4b87a8468742d4cb8abe51d62d4d9..23445bfaeed6d7a2642a1cd55becec9895fa5d0e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -47,6 +47,8 @@ else
   FPIC:=-fpic
 endif
 
+HOST_FPIC:=-fPIC
+
 ARCH_SUFFIX:=
 ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2
@@ -254,4 +256,16 @@ all:
 FORCE: ;
 .PHONY: FORCE
 
+val.%:
+       @$(if $(filter undefined,$(origin $*)),\
+               echo "$* undefined" >&2, \
+               echo '$(subst ','"'"',$($*))' \
+       )
+
+var.%:
+       @$(if $(filter undefined,$(origin $*)),\
+               echo "$* undefined" >&2, \
+               echo "$*='"'$(subst ','"'\"'\"'"',$($*))'"'" \
+       )
+
 endif #__rules_inc