u-boot.mk: add UBOOT_MAKE_FLAGS variable similar to MAKE_FLAGS
[openwrt/staging/yousong.git] / rules.mk
index e54acc9858287d3e0fba17c8c6ad4bb6c3914387..2586df3c27bce2050d7fdfd9fc5eb3cf61e2db25 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -101,12 +101,13 @@ ifdef CONFIG_MIPS64_ABI
   endif
 endif
 
-DEFAULT_SUBDIR_TARGETS:=clean download prepare compile install update refresh prereq dist distcheck configure check
+DEFAULT_SUBDIR_TARGETS:=clean download prepare compile install update refresh prereq dist distcheck configure check check-depends
 
 define DefaultTargets
-$(foreach t,$(DEFAULT_SUBDIR_TARGETS),
-  $(t):
-  .PHONY: $(t)
+$(foreach t,$(DEFAULT_SUBDIR_TARGETS) $(1),
+  .$(t):
+  $(t): .$(t)
+  .PHONY: $(t) .$(t)
 )
 endef
 
@@ -232,7 +233,7 @@ else
 endif
 
 export PATH:=$(TARGET_PATH)
-export STAGING_DIR STAGING_DIR_HOST
+export STAGING_DIR STAGING_DIR_HOST STAGING_DIR_HOSTPKG
 export SH_FUNC:=. $(INCLUDE_DIR)/shell.sh;
 
 PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config