package/madwifi: fix r23829 commit
[openwrt/staging/yousong.git] / rules.mk
index 23445bfaeed6d7a2642a1cd55becec9895fa5d0e..d3521649a52da662301b3f29eafc6486fe60e3b5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -249,6 +249,16 @@ define include_mk
 $(eval -include $(if $(DUMP),,$(STAGING_DIR)/mk/$(strip $(1))))
 endef
 
+# Execute commands under flock
+# $(1) => The shell expression.
+# $(2) => The lock name. If not given, the global lock will be used.
+define locked
+       SHELL= \
+       $(STAGING_DIR_HOST)/bin/flock \
+               $(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock \
+               -c '$(subst ','\'',$(1))'
+endef
+
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))