add openbsd compatibility patch (thanks, wbx)
[openwrt/staging/yousong.git] / scripts / config / lxdialog / Makefile
index a82b2bac993a77faff6edf1bb120916972af5523..aed08e0170e987e00ce73c655fa92a0634a28f9f 100644 (file)
@@ -7,7 +7,14 @@ all: lxdialog
 # we really need to do so. (Do not call gcc as part of make mrproper)
 CFLAGS := $(shell sh check-lxdialog.sh -ccflags)
 LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
+
+# workaround for OpenBSD, which does not use symlinks to libncurses.so
+OS := $(shell uname -s)
+ifeq ($(strip $(OS)),OpenBSD)
+LIBS := -lncurses
+endif
+
+
 always         := $(hostprogs-y) dochecklxdialog
 
 %.o: %.c