ar71xx: select ATH79_NVRAM only by boards actually use it
[openwrt/staging/yousong.git] / target / linux / ar71xx / modules.mk
index 18f0c4ae50b2867de76420b430be5792cb7a1d32..9ead8b451cec79c8848026b3b9485a85e186ced7 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+define KernelPackage/leds-nu801
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Meraki MR18 LED support
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_LEDS_NU801
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-nu801.ko
+  AUTOLOAD:=$(call AutoLoad,60,leds-nu801)
+endef
+
+define KernelPackage/leds-nu801/description
+ Kernel module for the nu801 LED driver used on the Meraki MR18.
+endef
+
+$(eval $(call KernelPackage,leds-nu801))
+
+
 define KernelPackage/leds-rb750
   SUBMENU:=$(LEDS_MENU)
   TITLE:=RouterBOARD 750 LED support
@@ -31,7 +47,23 @@ define KernelPackage/leds-wndr3700-usb
 endef
 
 define KernelPackage/leds-wndr3700-usb/description
- Kernel module for the USB LED on the NETGWR WNDR3700 board.
+ Kernel module for the USB LED on the NETGEAR WNDR3700 board.
 endef
 
 $(eval $(call KernelPackage,leds-wndr3700-usb))
+
+
+define KernelPackage/spi-vsc7385
+  SUBMENU:=$(SPI_MENU)
+  TITLE:=Vitesse VSC7385 ethernet switch driver
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_SPI_VSC7385
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-vsc7385.ko
+  AUTOLOAD:=$(call AutoLoad,93,spi-vsc7385)
+endef
+
+define KernelPackage/spi-vsc7385/description
+  This package contains the SPI driver for the Vitesse VSC7385 ethernet switch.
+endef
+
+$(eval $(call KernelPackage,spi-vsc7385))