at91: move legacy Kconfig options to subtarget
[openwrt/staging/yousong.git] / target / linux / at91 / Makefile
index 87f156a43af066e0bb791cd4c54f942d51818901..1c96492dac0de3a3cea08ac533301092b31b4823 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,15 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
-FEATURES:=squashfs usb
+FEATURES:=squashfs targz ext2 usb
+SUBTARGETS:=legacy sama5d3
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci
 
 $(eval $(call BuildTarget))