atheros: enable the low_mem flag to better deal with 16M RAM devices
[openwrt/staging/yousong.git] / target / linux / atheros / Makefile
index 6e29fd7d98b819c534a86d36fd4cf379e2b19060..1cfb6a6c745b412a3db6a45fbbce1e6ee83c42ef 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs low_mem
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-madwifi gpioctl swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards