atheros: enable the low_mem flag to better deal with 16M RAM devices
[openwrt/staging/yousong.git] / target / linux / atheros / Makefile
index 93f026b214dfaed525103465ad1d5328fbcd2f7b..1cfb6a6c745b412a3db6a45fbbce1e6ee83c42ef 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=atheros
-BOARDNAME:=Atheros
-FEATURES:=squashfs jffs2
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs low_mem
 
-LINUX_VERSION:=2.6.23.1
+LINUX_VERSION:=3.14.16
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards