update to 2.6.35.11
[openwrt/staging/yousong.git] / target / linux / brcm63xx / Makefile
index 32bfd06feaa4a243a5e474400b6207f52b120836..e5e2d55dd3feb629a099c1ab5aa965687aa6664c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=brcm63xx
-BOARDNAME:=Broadcom BCM963xx
-FEATURES:=squashfs jffs2 broken usb atm
+BOARDNAME:=Broadcom BCM63xx
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=2.6.35.11
+
+include $(INCLUDE_DIR)/target.mk
 
-LINUX_VERSION:=2.6.22.4
+DEFAULT_PACKAGES += kmod-switch gpioctl kmod-input-gpio-buttons \
+       kmod-leds-gpio kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       (e.g. Inventel Livebox, Siemens SE515)
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))