* adds support for speedport w502V
[openwrt/staging/yousong.git] / target / linux / ifxmips / Makefile
index 27ea078fb8ee2f038bf7a7f68705b0b4b3a3da80..4809e331007efb6b6818ae8eabcb8bfedb79004f 100644 (file)
@@ -9,22 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.33.4
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-define Target/Description
-       Build firmware images for Infineon Mips Controllers
-endef
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
 
-ifeq ($(KERNEL_PATCHVER),2.6.28)
-  define Kernel/Prepare
-       $(call Kernel/Prepare/Default)
-       mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
-  endef
-endif
+#define Target/Description
+#      Build firmware images for Infineon Mips Controllers
+#endef
 
 $(eval $(call BuildTarget))