* adds support for speedport w502V
[openwrt/staging/yousong.git] / target / linux / ifxmips / Makefile
index 8e96f7c664be1d333e1d4fd40990dcf0bb18b80a..4809e331007efb6b6818ae8eabcb8bfedb79004f 100644 (file)
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-SUBTARGETS:=generic nfs
-LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.12
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
+
+LINUX_VERSION:=2.6.33.4
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
 
-define Target/Description
-       Build firmware images for Infineon Mips Controllers
-endef
+#define Target/Description
+#      Build firmware images for Infineon Mips Controllers
+#endef
 
 $(eval $(call BuildTarget))