ipq806x: enable vfpv4 support and set cpu type to cortex-a9
[openwrt/staging/yousong.git] / target / linux / ipq806x / Makefile
index 6207c9126fead2d169bd3d459399331b32479086..97a40cfe0718db3a9e74d22ff2add1b97f40aaec 100644 (file)
@@ -5,14 +5,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
+FEATURES:=squashfs nand ubifs
+CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.18
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
+
 
 $(eval $(call BuildTarget))