lantiq: fix patches after 3.14.32 bump
[openwrt/staging/yousong.git] / target / linux / lantiq / patches-3.14 / 0023-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
index 3f53bf808f6500b664550730c7a47649f8f7091a..a60166e38e03aa66ffbfd4044b9d2fef12d4b1f9 100644 (file)
@@ -13,9 +13,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -157,6 +157,11 @@ config MICREL_PHY
-       ---help---
-         Currently has a driver for the KSZ8041
+@@ -152,6 +152,11 @@ config RTL8306_PHY
+       tristate "Driver for Realtek RTL8306S switches"
+       select SWCONFIG
  
 +config LANTIQ_PHY
 +      tristate "Driver for Lantiq PHYs"
@@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
+@@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
  obj-$(CONFIG_DP83640_PHY)     += dp83640.o
  obj-$(CONFIG_STE10XP)         += ste10Xp.o
  obj-$(CONFIG_MICREL_PHY)      += micrel.o