targets: prepare for supporting normal and initramfs images
[openwrt/staging/yousong.git] / target / linux / omap24xx / Makefile
index 1188a9c087201ae02543ace8e55d8f7dae005380..a91b0d2d13eb2829fb501b557a35b604bd240be5 100644 (file)
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap24xx
-BOARDNAME:=TI OMAP-24xx
+BOARDNAME:=TI OMAP24xx
 MAINTAINER:=Michael Buesch <m@bues.ch>
-FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
+FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
 
-LINUX_VERSION:=3.1.10
+LINUX_VERSION:=3.3.8
 
 define Target/Description
        TI OMAP-24xx
@@ -20,6 +20,8 @@ endef
 
 CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
 
+KERNELNAME:="zImage"
+
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))