targets: prepare for supporting normal and initramfs images
[openwrt/staging/yousong.git] / target / linux / omap24xx / Makefile
index 223376c3b49e05d7672a0edbc087b81a8e52c02d..a91b0d2d13eb2829fb501b557a35b604bd240be5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap24xx
-BOARDNAME:=TI OMAP-24xx
-MAINTAINER:=Michael Buesch <mb@bu3sch.de>
-FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
+BOARDNAME:=TI OMAP24xx
+MAINTAINER:=Michael Buesch <m@bues.ch>
+FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
 
-LINUX_VERSION:=2.6.36.1
+LINUX_VERSION:=3.3.8
 
 define Target/Description
        TI OMAP-24xx
 endef
 
+CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
+
+KERNELNAME:="zImage"
+
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))