update to the latest stable kernels
[openwrt/staging/yousong.git] / target / linux / orion / Makefile
index 2e2727ff14089cd7410ac786ca267e113e1f171f..627e2e3a493e078c6a577355f46b0ef79de57416 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
-FEATURES:=squashfs
+SUBTARGETS:=generic harddisk
+CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
-DEFAULT_PACKAGES += kmod-ath9k-new hostapd-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini
 
 $(eval $(call BuildTarget))