kernel: update kernel 4.9 to version 4.9.10
[openwrt/staging/yousong.git] / target / linux / ppc40x / Makefile
index 55ecbd0578d2866a5ad958877a106dff38768ef1..3529bb3db501e4eed0db5a4b4a40647324e389e9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -mcpu=405
+FEATURES:=squashfs broken
+CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.10
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
-KERNELNAME:="uImage cuImage.magicbox cuImage.openrb"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
 
 $(eval $(call BuildTarget))