global cflags: remove -funit-at-a-time, it is ignored by recent compilers. instead...
[openwrt/staging/yousong.git] / target / linux / ppc44x / Makefile
index dd30aa8cc45b55c3db0d41f71367e0065639063e..b13261a9d2ba8055b4117ed87e78be43a9c030f8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,15 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.28.9
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=2.6.32.33
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))