major target cleanup. it is now possible to have subtargets that can override many...
[openwrt/staging/yousong.git] / target / linux / pxa / Makefile
index 3e0e6cd3b33d945db9c1b8cea3f7edd3e8741a07..ad44af27e47dad02aa91c00f55306a21f7225496 100644 (file)
@@ -13,13 +13,13 @@ FEATURES:=jffs2 broken
 
 LINUX_VERSION:=2.6.21.5
 
+include $(INCLUDE_DIR)/target.mk
+
 define Target/Description
        Stub for boards based on intel PXA
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
 # include the profiles
 -include profiles/*.mk
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))