build: remove mips16 feature flag from target makefiles
[openwrt/staging/yousong.git] / target / linux / ramips / Makefile
index 95577d4af88b9048355af43f43c35f07d493877d..25859024c1021a33ffbe40e14b1a74f33376584a 100644 (file)
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x mt7620 mt7621 mt7628 rt3883 rt288x
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
 FEATURES:=squashfs gpio
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.14
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+
 $(eval $(call BuildTarget))