mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after...
[openwrt/staging/yousong.git] / target / linux / ramips / Makefile
index e165da6f239be0351bb405cd2831c85198429bc7..ba00c926829f36fdb6205d4f35cff74af683a034 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
 LINUX_VERSION:=3.6.11