ramips: remove kmod-mt76* from EX2700 images
[openwrt/staging/yousong.git] / target / linux / ramips / image / mt7620.mk
index 446bd9981e28bec21f62416fcca05b85d8ec8f2a..9a2941ce99f42d85e8823d92c6bc9635cd9214ca 100644 (file)
@@ -61,6 +61,7 @@ define Device/ex2700
   KERNEL := $(KERNEL_DTB) | uImage lzma | pad-offset 64k 64 | append-uImage-fakeroot-hdr
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
        netgear-dni
+  DEVICE_PACKAGES := -kmod-mt76
   DEVICE_TITLE := Netgear EX2700
 endef
 TARGET_DEVICES += ex2700
@@ -465,3 +466,11 @@ define Device/kng_rc
        zyimage -d 8997 -v "ZyXEL Keenetic Viva"
 endef
 TARGET_DEVICES += kng_rc
+
+define Device/d240
+  DTS := D240
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  DEVICE_TITLE := Sanlinking Technologies D240
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += d240