squash platform_support.patch into rdc_boards.patch
[openwrt/staging/yousong.git] / target / linux / rdc / patches-2.6.32 / 100-rdc_boards.patch
index f2a148e9c20f5ae8f37a606c82720bd1031d31e3..9012cb344a3d1e751d2a5d0228f2848c06305bf3 100644 (file)
@@ -1,3 +1,16 @@
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -125,6 +125,9 @@ libs-y  += arch/x86/lib/
+ # See arch/x86/Kbuild for content of core part of the kernel
+ core-y += arch/x86/
++# RDC R-321X support
++core-$(CONFIG_X86_RDC321X)   += arch/x86/mach-rdc321x/
++
+ # drivers-y are linked after core-y
+ drivers-$(CONFIG_MATH_EMULATION) += arch/x86/math-emu/
+ drivers-$(CONFIG_PCI)            += arch/x86/pci/
+
 --- /dev/null
 +++ b/arch/x86/mach-rdc321x/Makefile
 @@ -0,0 +1,5 @@