update to 2.6.32.33 and 2.6.37.4
[openwrt/staging/yousong.git] / target / linux / sibyte / Makefile
index 35cdb37f2ec188409014d96ab0c3d8fd45a0c3c4..6614b82fc015e570be25e8c6883871aa63ad6ba5 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=sibyte
-BOARDNAME:=SiByte MIPS
-FEATURES:=broken
+BOARDNAME:=Broadcom/SiByte SB-1
+FEATURES:=fpu
+CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.32.33
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+define Target/Description
+       Build firmware images for Broadcom/SiByte SB-1 boards
+endef
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))