x86: remove grub-legacy
[openwrt/staging/yousong.git] / target / linux / x86 / image / Makefile
index 17e300d5080be33483c7661e7bdf3cc298039c6a..028612a12eacb9d1e4f8d7e5f0754d025c43edc6 100644 (file)
@@ -28,11 +28,7 @@ ifneq ($(CONFIG_X86_GRUB_SERIAL),)
 endif
 
 ifneq ($(GRUB_TERMINALS),)
-  ifneq ($(CONFIG_X86_USE_GRUB2),)
-    GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
-  else
-    GRUB_TERMINAL_CONFIG := terminal --timeout=2 $(GRUB_TERMINALS)
-  endif
+  GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
@@ -59,38 +55,6 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
     block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
   endef
 
-  define Image/Build/grub
-       # left here because the image builder doesnt need these
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(KDIR)/stage1 \
-               $(KDIR)/stage2 \
-               $(KDIR)/e2fs_stage1_5 \
-               $(KDIR)/root.grub/boot/grub/
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
-       sed \
-               -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
-               -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_grub.sh \
-               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
-               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
-               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
-       $(call Image/Build/grub/$(1))
-  endef
-
-  define Image/Prepare/grub
-       # for the image builder
-       $(CP) \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/stage1 \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/stage2 \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/stage2_eltorito \
-               $(STAGING_DIR)/usr/lib/grub/i386-openwrt/e2fs_stage1_5 \
-               $(KDIR)/
-  endef
-
   define Image/Build/grub2
        # left here because the image builder doesnt need these
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
@@ -160,8 +124,7 @@ define Image/Build/squashfs
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
-ifdef CONFIG_X86_USE_GRUB2
-  define Image/Build/iso
+define Image/Build/iso
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
@@ -182,24 +145,7 @@ ifdef CONFIG_X86_USE_GRUB2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
                -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
-  endef
-else
-  define Image/Build/iso
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(KDIR)/stage2_eltorito \
-               $(KDIR)/root.grub/boot/grub/ 
-       sed \
-               -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
-               -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-               -e 's#(hd0,0)#(cd)#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz 
-       mkisofs -R -b boot/grub/stage2_eltorito -no-emul-boot -boot-load-size 4 -boot-info-table \
-               -o $(KDIR)/root.iso $(KDIR)/root.grub 
-  endef
-endif
+endef
 
 ifneq ($(CONFIG_X86_VDI_IMAGES),)
   define Image/Build/vdi
@@ -263,14 +209,14 @@ endef
 define Image/Prepare
        $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
        $(call Image/Prepare/bootscript)
-       $(call Image/Prepare/$(if $(CONFIG_X86_USE_GRUB2),grub2,grub))
+       $(call Image/Prepare/grub2)
 endef
 
 define Image/Build
        $(call Image/Build/$(1))
        $(call Image/Build/bootscript,$(1))
   ifneq ($(1),iso)
-       $(call Image/Build/$(if $(CONFIG_X86_USE_GRUB2),grub2,grub),$(1))
+       $(call Image/Build/grub2,$(1))
        $(call Image/Build/vdi,$(1))
        $(call Image/Build/vmdk,$(1))
   endif