ar71xx: Add profile and build image for TP-Link MR12U v1
[openwrt/staging/yousong.git] / target / sdk / files / Makefile
index 7f42b697ab18867272759dbde3dc5f3c43dd3c8e..2edf7b3a20461b81b122261976f33bef9845ff7d 100644 (file)
@@ -1,72 +1,59 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007-2015 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+SDK:=1
+export TOPDIR LC_ALL LANG SDK
 
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+world:
 
-DEVELOPER=1
-export DEVELOPER
+include $(TOPDIR)/include/host.mk
 
-SDK=1
-export SDK
+ifneq ($(OPENWRT_BUILD),1)
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
 
-all: world
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=export MAKEFLAGS=$(space);
 
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
+  include $(TOPDIR)/include/toplevel.mk
+else
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include package/Makefile
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+$(package/stamp-compile): $(BUILD_DIR)/.prepared
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
 
-package/%: .pkginfo FORCE
-       $(MAKE) -C package $(patsubst package/%,%,$@) SDK=1
+clean: FORCE
+       git clean -f -d $(STAGING_DIR); true
+       git clean -f -d $(BUILD_DIR); true
+       git clean -f -d $(BIN_DIR); true
 
-download: FORCE
-       $(MAKE) package/download
+dirclean: clean
+       git reset --hard HEAD
+       git clean -f -d
+       rm -rf feeds/
 
-world: FORCE
-       $(MAKE) package/compile
-       -( \
-               cd package; \
-               find . -maxdepth 2 -name Config.in | \
-                       sed -e 's,/Config.in,,g' | \
-                       xargs -r -n1 make compile -C; \
-       )
+# check prerequisites before starting to build
+prereq: $(package/stamp-prereq) ;
 
-clean: FORCE
-       rm -rf build_* bin
+world: prepare $(package/stamp-compile) FORCE
+       @$(MAKE) package/index
 
-distclean: clean
-       rm -rf dl .pkg*
+.PHONY: clean dirclean prereq prepare world
 
-.PHONY: FORCE
-FORCE:
+endif