gcc: use qstrip template to fix syntax highlighting
[openwrt/staging/yousong.git] / toolchain / gcc / common.mk
index 0a148ce97fa06776903a6722c0409ad570c5cdb7..b33769ce504335aa750cb7db1a8b27f8be0449c1 100644 (file)
@@ -53,9 +53,6 @@ else
   PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
-  ifeq ($(PKG_VERSION),4.6.3)
-    PKG_MD5SUM:=773092fe5194353b02bb0110052a972e
-  endif
   ifeq ($(PKG_VERSION),4.8.0)
     PKG_MD5SUM:=e6040024eb9e761c3bea348d1fa5abb0
   endif
@@ -122,7 +119,7 @@ GCC_CONFIGURE:= \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
-                       --with-abi=$(subst ",,$(CONFIG_MIPS64_ABI))) \
+                       --with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --with-mpc=$(TOPDIR)/staging_dir/host \