fix up the asm includes location for .27 when building kernel headers
[openwrt/staging/yousong.git] / toolchain / kernel-headers / Makefile
index 4443c43463e224fa1acb2f9bde0509d22f3391f4..a182c83c1ff76b44b5b862c64fc1f44fd19d10cf 100644 (file)
@@ -53,6 +53,11 @@ define Build/Prepare
        ln -sf linux-$(LINUX_VERSION) $(LINUX_HEADERS_DIR)
        yes '' | $(KMAKE) oldconfig
        $(KMAKE) include/linux/version.h include/asm
+       if [ -d $(PKG_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm ]; then \
+               $(CP) \
+                       $(PKG_BUILD_DIR)/arch/$(LINUX_KARCH)/include/asm/. \
+                       $(PKG_BUILD_DIR)/include/asm-$(LINUX_KARCH)/; \
+       fi
        $(call Build/Configure/$(ARCH))
 endef