build: decouple the mips16 support flag from the toolchain
[openwrt/staging/yousong.git] / toolchain / uClibc / common.mk
index dec4a1c741f825d949745f24a535776d9f095e1c..69ac470b029b8a3b94fe2c53543ac258832bad4f 100644 (file)
@@ -45,13 +45,11 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
                        $(if $(CONFIG_MIPS64_ABI),.$(subst ",,$(CONFIG_MIPS64_ABI)), \
                        $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500)))))
 
-TARGET_CFLAGS := $(filter-out -mips16,$(TARGET_CFLAGS))
-
 CPU_CFLAGS = \
        -funsigned-char -fno-builtin -fno-asm \
        --std=gnu99 -ffunction-sections -fdata-sections \
        -Wno-unused-but-set-variable \
-       $(TARGET_CFLAGS)
+       $(TARGET_CFLAGS) -ggdb
 
 UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
        $(TARGET_CONFIGURE_OPTS) \