add a command for printing a cleaned up make target database - will be used to analyz...
[openwrt/staging/yousong.git] / tools / Makefile
index 6e364af7a9777593ef8d38cb0218682d7f8a4516..5a5c728ab7819f7aba9a53c483ad8fa6537693b8 100644 (file)
@@ -54,6 +54,7 @@ $(curdir)/upslug2/compile := $(curdir)/automake/install
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)
 
+ifndef DUMP_TARGET_DB
 define PrepareStaging
        @for dir in $(1); do ( \
                set -x; \
@@ -84,6 +85,7 @@ $(STAGING_DIR_HOST)/bin/$(1): $(STAGING_DIR)/.prepared
        }; ln -s "$$$$FILE" "$$@"
 
 endef
+endif
 
 $(eval $(call PrepareCommand,find,gfind find))
 $(eval $(call PrepareCommand,md5sum,md5sum $(SCRIPT_DIR)/md5sum))