pkg-config: link statically
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 19:26:46 +0000 (19:26 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 10 Aug 2012 19:26:46 +0000 (19:26 +0000)
SVN-Revision: 33102

tools/pkg-config/Makefile

index e7d2982f7f45cd9694aad027a5772613fbed13da..fbdc1d0db7cf288f8bed862f528c2cdffddc2294 100644 (file)
@@ -15,9 +15,10 @@ PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_LDFLAGS += -static
+
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) \
-               install
+       $(MAKE) -C $(HOST_BUILD_DIR) install AM_LDFLAGS="-all-static"
        mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real
        $(INSTALL_BIN) ./files/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config
 endef