ca-certificates: add system CA certificates package (based on the debian one)
authorFelix Fietkau <nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:22 +0000 (15:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:22 +0000 (15:54 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39984

package/system/ca-certificates/Makefile [new file with mode: 0644]

diff --git a/package/system/ca-certificates/Makefile b/package/system/ca-certificates/Makefile
new file mode 100644 (file)
index 0000000..f8fdf59
--- /dev/null
@@ -0,0 +1,41 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ca-certificates
+PKG_VERSION:=20140223
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/c/ca-certificates
+PKG_MD5SUM:=ff4049c32342ea450cda82bb14026ffd
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ca-certificates
+  SECTION:=base
+  CATEGORY:=Base system
+  TITLE:=System CA certificates
+endef
+
+define Build/Install
+       mkdir -p \
+               $(PKG_INSTALL_DIR)/usr/sbin \
+               $(PKG_INSTALL_DIR)/usr/share/ca-certificates
+       $(call Build/Install/Default,)
+endef
+
+define Package/ca-certificates/install
+       $(INSTALL_DIR) $(1)/etc/ssl
+       ln -s ../../usr/share/ca-certificates $(1)/etc/ssl/certs
+       $(INSTALL_DIR) $(1)/usr/share/ca-certificates
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/ca-certificates/*/*.crt $(1)/usr/share/ca-certificates/
+endef
+
+$(eval $(call BuildPackage,ca-certificates))