when building a package, make sure that older versions get removed
authorFelix Fietkau <nbd@openwrt.org>
Fri, 16 Feb 2007 01:00:01 +0000 (01:00 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 16 Feb 2007 01:00:01 +0000 (01:00 +0000)
SVN-Revision: 6303

include/package.mk

index 12e4190ef81bc56b2d03588c2a7a898eb072a461..84575169bed679404fc2dceb3823ae3aa2b78016 100644 (file)
@@ -213,6 +213,7 @@ define BuildPackage
   $(eval $(call BuildIPKGVariable,$(1),prerm))
   $(eval $(call BuildIPKGVariable,$(1),postrm))
   $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH)
+       @rm -f $(PACKAGE_DIR)/$(1)_*
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
        echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control